cancel
Showing results for 
Search instead for 
Did you mean: 

RT-AC5300 dead?

m9x3mos
Level 7

Hello all,
I am wondering if there is anything else you might be able to recommend.
This morning I woke up to my internet not working through my RT-AC5300 that I have been using for a few years. (only running stock firmware)
At first I was seeing wifi after rebooting it but on a second reboot, the wifi does not broadcast anymore nor can I access anything on it.
I have tried resetting it by holding the reset button for 10 seconds with it on, I have tried the reset with the WPS button, as well as the Asus Recovery mode flash.
The recover appeared to work saying that it was successful, but I am still not able to access it on 192.168.1.1 or it's previous 10.1.10.1 address.
Not sure if something else crashed or if there is anything else I can do to try and get it working.
My tests with the resets has been with only power and the laptop plugged into it to rule out other issues that might have been on the network.
I also notice that when I boot it up, the power light comes on but that is all no matter what else I connect. (wan, etc.)
It also doesn't really seem to be getting warm like it was before.
My best guess is something is hanging during boot for some reason but I am not sure how to fix it.
Any advice you could provide would be greatly appreciated.

133 Views
1 REPLY 1

jzchen
Level 14

Is there any burnt smell?  You could open it and check for any signs something burned out:

https://youtu.be/b13hhJHndsw?si=m01fYA84RHKWe99W