Showing results for 
Search instead for 
Did you mean: 

ROG Rapture GT-AC5300 - Firmware [report if any issues]

Level 7
New firmware ( just got released for the ROG Rapture GT-AC5300.

Please share your findings here in this thread. Thanks people!

Release notes:

ASUS GT-AC5300 Firmware version
- Improved AiMesh dedicated backhaul mechanism for tri-band to tri-band AiMesh modes.
- Lyra, Lyra Mini, and Lyra Trio can be added as AiMesh node into GT-AC5300 network.
Please refer to for more detail.

- Fixed CVE-2018-14710, CVE-2018-14711, CVE-2018-14712, CVE-2018-14713, CVE-2018-14714. Thanks for Rick Ramgattie's contribution.
- Fixed AiCloud/ Samba account vulnerability. Thanks for Matthew Cundari's contribution.
- Fixed DoS vulnerability. Thanks for Ruikai Liu's contribution.
- Fixed CVE-2018-17020, CVE-2018-17021, CVE-2018-17022.
- Fixed stored XSS vulnerability. Thanks for Duda Przemyslaw's contribution.
- Updated OpenSSL library.

New Alexa skill and IFTTT actions
- Add Alexa skill “ ask ASUS ROUTER to report security status”
- Add Alexa skill “ ask ASUS ROUTER how many devices are online”
- Add IFTTT actions : Wake on LAN
- Add IFTTT actions : check new firmware available and upgrade
[Note] You have to upgrade the firmware version up to if you want to use these new Alexa skills and IFTTT actions.

Bug fixes and improvement
- Improved wireless stability.
- Modified “Dual Wan” user interface.
- Modified “Port Forwarding” user interface.
- Modified “Restore” user interface.
- Fixed “VPN Fusion” bugs.
- Fixed GUI bugs on user feedback page.
- Fixed “Adaptive QoS” bugs.
209 REPLIES 209

I have been experiencing many issues my ROG Rapture GT-AC5300 for the last few firmware updates. I am currently using My download and upload speeds through this router have dropped and even frozen at times. I have a 400meg internet plan with Spectrum. They came and replaced my Docsis 3.0 modem to a Docsis 3.1 modem and it is still giving me erratic fluctuations in internet speeds. Spectrum confirmed yesterday that I have an excellent signal, both inside and outside the house. The Spectrum guy was pulling around 460meg with his laptop direct to the new cable modem. I am using my pc connection hard wired to this router and my speeds fluctuate from 25meg up to 435meg during the same time period that he was here while we were testing and my pings were higher than normal. We both used the same server for speed testing. Prior to these last few firmware upgrades, my speeds were consistently in the 380 to 440 range which is what I would expect on the 400meg plan. Also, the Wifi on almost all of my devices have been dropping off randomly. I have to reboot the router, unplug and reboot the devices in order for these devices to resync to the Wifi. I didn't have this problem previously. I have tried a factory reset of the router and my pc and started fresh with everything and it still has the same problems on the pc and the other devices (ROKUs, LG phones, Samsung phone, laptops and security cameras). Also, I used to be able to log into the router using Microsoft Edge using or it's IP Address stating Can't Reach this page, but I can reach the router using Firefox using this method or from the Android app for the router. Any help would be appreciated.

In order to fix the speed with version you have to turn QoS off,.. and this cannot be doing from the QoS menu.
But it can be turned off by turning Game Boost off from the Game Acceleration menu.

Run a speed test before and after turning it on|off.

Maybe a idea to open a topic for FW and make it sticky as well?

poudenes wrote:
Maybe a idea to open a topic for FW and make it sticky as well?

That firmware is for the GT-AX11000. Will flashing the GT-AX11000 firmware on to the GT-AC5300 work?

Jesseinsf wrote:
That firmware is for the GT-AX11000. Will flashing the GT-AX11000 firmware on to the GT-AC5300 work?

tbh all the underlying firmware is based on OpenWRT but there is some closed source... nothing stops you from compiling your own version of the GT-AC5300 opensource which is available by going to Drivers & Tools / Others / Source Code located here

I would look at the Merlin RT-AC5300 firmware which is feature rich and stable, if your good at coding and getting up an environment to compile the firmware nothing stops you from using parts of Merlin RT-AC5300 with GT-AC5300

The best router model from ASUS has not been updated since March 2020 ??? RT-AC5300, RT-AC68U, RT-AC86U etc devices have already had 3 updates since March 2020 !!!

Asus gave up this model?

muzykcb wrote:
The best router model from ASUS has not been updated since March 2020 ??? RT-AC5300, RT-AC68U, RT-AC86U etc devices have already had 3 updates since March 2020 !!!

Asus gave up this model?

If you check for a firmware update on the router UI there is a new AC5300 firmware.

I can't find anything online about it and it doesn't seem to have posted to the Asus official download site yet.

Please Update the Background in

I can't believe this is an ROG , but you can't customize the theme ! which is ridiculous!
Please feed my back if any update coming regard cosmetic update coming soon

There is a bug that I reported for the newest Firmware (Version 2020/03/06 59.05 MBytes) that I also reported for the most recent Beta prior to the new firmware released, but was not addressed.


1) Amazon Echo devices will no longer play any songs from Amazon Music (disables Amazon's Music service). Amazon will respond to a request to play music, but the song will not actually play.

2) Other device apps, such as the Coway Airmega system, will no longer be able to connect to devices on your local network. You can use a VPN (or a cellular connection) and they will connect fine. This means that it is definitely the new firmware. Also, if you downgrade to the version that was available prior to the most recent beta and newest public release, everything works perfectly.

I also tried manually opening all ports that could be used by Amazon Music and these other device apps which did not work either.

This is a bug that was reported as soon as the beta was released via the Asus ticket system and the support team said they would tell this developers. Unfortunately, it looks like it was not addressed for the post-beta release.

If anyone has an alternative solution, please post it. Also, if Asus reads these, please take the time to investigate this issue. I also wrote back to Efriam who was the support agent that indicated he would inform the developers of the problem.

With potentially thousands, if not millions of people who use Amazon Music via an Echo device impacted, I'm guessing this will be a big deal and the average person won't be able to figure it out (or will stop using Asus networking products).

Any help from the community is appreciated.


This firmware update also causes the firestick to be unable to download updates to is FireOS. It will identify an update is needed an hang indefinitely on the download. When I revert back to the last final firmware, it works fine.