Showing results for 
Search instead for 
Did you mean: 

Impossible to create offline AiMesh network!

Level 7
Backstory: I have 3x RT-AX92U, and until yesterday they were running fine in a mesh configuration, with one node on wired backhaul and one wireless. I updated them from the 384-series firmware to 386, and at one point in the process the AP showed the nodes as "offline". I thought maybe the whole setup would be happier after a factory reset, so I reset all 3 devices (hard reset, using WPA button) and started from scratch. During this process, I was unable to add mesh nodes, always getting the "unable to add, please check and try again" popup. I tried multiple factory resets, re-flashing the new firmware, downgrading to the old firmware, everything I could think of.

It's working now, but it took **hours**. Here's the problem: while reconfiguring the devices, I never plugged them into my internet connection. It didn't occur to me, I just put the devices next to each other on a table, turned off my laptop wifi, and used a cable to connect to each in turn. I was setting them up in AP mode so I didn't think there was any reason to need network access during setup.

Then I looked at the system logs on the AP, and realized that it was constantly trying (and failing) to run an NTP update. I checked the Admin settings and found that while I can point it at a different NTP server, I cannot manually update the clock. On a hunch, I plugged the AP's WAN port into my ISP router, and checked the logs again to make sure it had updated the time successfully, then tried to add a node again. It worked the first time.

My operating theory is that at some point in the adding process, SSL certificate verification failed due to clock skew. I'm not positive, but updating the clock on the AP is the only thing I did differently between the dozen or so failed attempts, and the one that finally worked. If I'm right about my theory, it means that it's impossible to successfully add a mesh node without connecting to an NTP server.

It also means that Asus needs to do a better job of surfacing a useful error message for this situation. Better yet, disable the "add node" feature completely until system time has been set at least once.