cancel
Showing results for 
Search instead for 
Did you mean: 

Help Proper Config GT-AX11000 2.5ge + 2.5ge switch + 2.5g modem for over 1gbps...

thecolin85
Level 7
Hi all, newbie here, please be patient with me. I have a "weekend-warrior" level knowledge of tech stuff, but I'm no networking expert. Otherwise I probably wouldn't be asking these questions…
I cannot get my current configuration to provide my 1200mbps+ speeds across multiple devices, even after doing all this research months back and thinking, "Oh if I just buy a multi-port 2.5g switch, I won't have all my devices throttled below 1gbps. And I had thought I had it figured out at one point. I swore I had it once where if I plugged my desktop PC in hardwired, I would get those 1300mbps+ speedtest results, but on WiFi it would NEVER break 1000mbps. Always 900-something mbps. I tried tweaking the router settings, maybe sure all drivers and firmware all up to date etc. No dice.

My hardware:



Also running the router on the latest firmware of Asuswrt-Merlin. Desktop PC is an x570 Crosshair Hero VIII Wi-Fi (FWIW).

I have tried so many different configurations (using at least CAT6A, CAT7 or CAT8 cables) of what to plug into what first. Currently I have the 2.5g port out of the S33 modem and into the 2.5g port on the AX11000 router. Then out of the AX11000 router's blue (WAN?) port and into one of the four 2.5g ports on the switch. Then out of the switch, I have a 2.5g port and cable running to my desktop PC's 2.5g onboard ethernet port.

I verified I can get 1300 and nearly 1400 mbps speeds when I run the 2.5ge port on the S33 modem straight to my desktop PC. I've also verified I can break over 1gbps Wi-Fi speeds on various PC devices (desktop, laptop) and mobile phones when plugged into the 2.5g port on the router, but then anything hardwired is capped at 900-something MBPS.

I don't know if I should run the modem 2.5ge straight to the router first, then to the switch? Or to the switch, then back to the router… Or am I screwed or limited by the hardware somehow? Should I run a cable from the S33 modem's 2.5ge port to the router's 2.5ge port and then run another cable from the S33 modem's 1ge port to the blue "WAN" port on the AX11000 router?

I could care less if all Wi-Fi devices were capped below 1000 mbps / 1gbps as long as I could have at least my own desktop PC device able to get over 1000mbps when hardwired especially.
12,720 Views
70 REPLIES 70

I honestly believe the FAQ is just a standard response from Asus or maybe just saying they don't support it as it would open possibilities for many other customers contacting them on random USB adapters. As I mentioned before, it works perfectly fine for me (even though I don't have the same speed you have, I do get over 1gbps on my network).

Have you tried @jzchen's suggestion and changed USB ports and mode to legacy?

I wouldn't know what else to do in this case, unfortunately.