cancel
Showing results for 
Search instead for 
Did you mean: 

Help Proper Config GT-AX11000 2.5ge + 2.5ge switch + 2.5g modem for over 1gbps...

thecolin85
Level 7
Hi all, newbie here, please be patient with me. I have a "weekend-warrior" level knowledge of tech stuff, but I'm no networking expert. Otherwise I probably wouldn't be asking these questions…
I cannot get my current configuration to provide my 1200mbps+ speeds across multiple devices, even after doing all this research months back and thinking, "Oh if I just buy a multi-port 2.5g switch, I won't have all my devices throttled below 1gbps. And I had thought I had it figured out at one point. I swore I had it once where if I plugged my desktop PC in hardwired, I would get those 1300mbps+ speedtest results, but on WiFi it would NEVER break 1000mbps. Always 900-something mbps. I tried tweaking the router settings, maybe sure all drivers and firmware all up to date etc. No dice.

My hardware:



Also running the router on the latest firmware of Asuswrt-Merlin. Desktop PC is an x570 Crosshair Hero VIII Wi-Fi (FWIW).

I have tried so many different configurations (using at least CAT6A, CAT7 or CAT8 cables) of what to plug into what first. Currently I have the 2.5g port out of the S33 modem and into the 2.5g port on the AX11000 router. Then out of the AX11000 router's blue (WAN?) port and into one of the four 2.5g ports on the switch. Then out of the switch, I have a 2.5g port and cable running to my desktop PC's 2.5g onboard ethernet port.

I verified I can get 1300 and nearly 1400 mbps speeds when I run the 2.5ge port on the S33 modem straight to my desktop PC. I've also verified I can break over 1gbps Wi-Fi speeds on various PC devices (desktop, laptop) and mobile phones when plugged into the 2.5g port on the router, but then anything hardwired is capped at 900-something MBPS.

I don't know if I should run the modem 2.5ge straight to the router first, then to the switch? Or to the switch, then back to the router… Or am I screwed or limited by the hardware somehow? Should I run a cable from the S33 modem's 2.5ge port to the router's 2.5ge port and then run another cable from the S33 modem's 1ge port to the blue "WAN" port on the AX11000 router?

I could care less if all Wi-Fi devices were capped below 1000 mbps / 1gbps as long as I could have at least my own desktop PC device able to get over 1000mbps when hardwired especially.
12,529 Views
70 REPLIES 70

Hello - I have the GT-AXE11000 and went on this ASUS USB-C2500 journey.  Without QOS/AI Protect, I do not get over 1Gbps download, but I do with upload on my 2Gbps up/down plan.  A unfortunate as that sounds my last resort is to see if a Cat6a cord may remedy this but I’m low key doubting it.

I get better speeds on my devices without the USB, using the 2.5Gbps port, but then all my AiMesh nodes are downgraded to 1Gbps using Ethernet/Mocha backhaul.  Kind of a bummer.  

I could connect my Mocha adapter directly to my modem for max avail speed but this would require me to redo my entire AiMesh setup since the nodes no longer directly talk to the GT-AXE11000 router.

It seems the next step up is the ROG Rapture GT-BE98, when it becomes off of back order or another device that has multiple Ethernet ports rated higher than 1Gbps..

 

If the 6A cable resolves it I’ll reply back but also I will welcome anyone who may know what settings to adjust for the ROG router for the USB input because it seems to think it’s a LTE USB device…

 

IMG_0758.png

IMG_0759.png

I'm sorry the USB adapter failed to give positive results.  I did see someone using it on this forum.  I figured it would work.  Regarding your download issue I do believe the ethernet upload lines and download lines are separate, so if you have a defective cable this may explain what you are seeing.  Very long lengths do affect signal but I can't imagine someone having that long.  As background I had my house wired back in 2003/2004 when it was built with Cat 5e (550 MHz) cable.  It was quite expensive back then.  It appears to support my 10 Gig backhaul.  I connect high spec Cat 8 cable from the wall socket to switches...

I purchased a USB to ethernet adapter from Walmart, not ASUS brand, and has USB C to USB A dongle.  If I get a chance I may try with my setup here, and report.  My download speed is 10xx most of the time from router speed tests....

Hi, I’ve been using the USB solution ever since that thread without issues.

That being said, the router never gets the full speed on the speed test, I believe it’s something related to the Trend Micro protections, or a bug in the router software when using the USB adapter.

I really didn’t mind going after a solution, because other than the router itself, all other devices on the network behind the router do get full speed, as per speed tests done individually on each of them.

My upload speed is very limited on my Comcast plan, so I never saw a speed test over 1gbps on my router, but I suggest you test the speed on your computer directly.

If you still have issues, please let me know and I’ll send a few screenshots of my router setup.

Hey BertoAndrade, thanks for chiming in.  We have a very similar setup!  I have Fiber 2Gbps up/down that I connect a Cat6 cable from the 10Gbps port into the ASUS USB 2500 and then plug that into one of the GT-AXE11000 USB 3.2 ports.  From there I use the 2.5Gbps WAN port to connect to a goCoax MA2500D 2.5Gbps Mocha adapter system that serves as an Ethernet backhaul for 2 ZenWifi XT8 nodes.  

I tried your suggestion of directly connecting the ASUS USB adapter to my laptop and I see what you mean about the USB have limiting performance when connected to the router.  On my laptop, I am getting 1.5Gbps download/2.2Gbps upload, whereas as you saw in the previous post - the router without QoS and AiProtect is getting 750Mbps download/1500Mbps upload using that USB pathway, whereas if I use the 2.5Gbps WAN port directly to the modem, I get very close to 2Gbps up/down.

 

I saw in your post that you were getting almost the  full 1.2Gbps on your nodes?  Wondering if you might have any different settings to break over 1Gbps download?  Now that I am thinking about it, I almost wonder if the router is using the USB in half duplex - but not sure how to check.  Both green lights are lit on it.

IMG_0792.jpeg

 Here is a screenshot of the USB modem settings on my router if it helps reference too!

Happy new year!

I am not sure if I was clear on my response, but my suggestion was not to plug the USB adapter to the notebook.

What I said I did is let go of the router not showing the full speed in its embedded speed test. The embedded speed test seems be affected by the router processing and not show true results. I kept the USB modem connected to the router and my network plugged into the 2.5gbe port in the router and then did a speed test on the computers on the other end. They were all showing full speed even though the router’s speed test does not show it.

Something to notice is I don’t have a >1.5gbps connection to test if I’d break that barrier with the USB adapter. But I do confirm all of my nodes and the computers on the other end get 1.2gbps (I have a 2.5gbps switch between the MoCA adapter and one of the nodes and my main computer is plugged directly to switch so I’m able to test the full speed is reaching the node) even though the router’s embedded speed test always returns something around 650mbps.

Happy New Year!

Actually what you noted, and clearly defined in your latest post, was what I understood from your initial response.  I did not grasp the vastness of the discrepancy from 650 Mbps on router speed test to 1.2 Gbps actually reaching the clients, so thank you for clarifying that.

I do remember trying to help you with your switch issue.  Boy, I did not even know that those manufacturers even existed.  I have stuck with TP-Link and TRENDnet switches since those companies first opened sales to the US, and prior to that Netgear and D-Link*.  *I forget the chronology now of D-Link but…

Hopefully @TonyDTiger will have a similar surprise/luck with full speeds at his clients…

There are so many brands being sold at Amazon and the 2.5gbe switches from known brands are still overpriced, so I did test a few brands until I was able to get one working well, and it’s been very stable ever since. The managed switch from Sodola is actually pretty good. I’ve changed my NAS to 2.5gbe since then and have been getting fast speeds inside my network.