Showing results for 
Search instead for 
Did you mean: 

Help Proper Config GT-AX11000 2.5ge + 2.5ge switch + 2.5g modem for over 1gbps...

Level 7
Hi all, newbie here, please be patient with me. I have a "weekend-warrior" level knowledge of tech stuff, but I'm no networking expert. Otherwise I probably wouldn't be asking these questions…
I cannot get my current configuration to provide my 1200mbps+ speeds across multiple devices, even after doing all this research months back and thinking, "Oh if I just buy a multi-port 2.5g switch, I won't have all my devices throttled below 1gbps. And I had thought I had it figured out at one point. I swore I had it once where if I plugged my desktop PC in hardwired, I would get those 1300mbps+ speedtest results, but on WiFi it would NEVER break 1000mbps. Always 900-something mbps. I tried tweaking the router settings, maybe sure all drivers and firmware all up to date etc. No dice.

My hardware:

Also running the router on the latest firmware of Asuswrt-Merlin. Desktop PC is an x570 Crosshair Hero VIII Wi-Fi (FWIW).

I have tried so many different configurations (using at least CAT6A, CAT7 or CAT8 cables) of what to plug into what first. Currently I have the 2.5g port out of the S33 modem and into the 2.5g port on the AX11000 router. Then out of the AX11000 router's blue (WAN?) port and into one of the four 2.5g ports on the switch. Then out of the switch, I have a 2.5g port and cable running to my desktop PC's 2.5g onboard ethernet port.

I verified I can get 1300 and nearly 1400 mbps speeds when I run the 2.5ge port on the S33 modem straight to my desktop PC. I've also verified I can break over 1gbps Wi-Fi speeds on various PC devices (desktop, laptop) and mobile phones when plugged into the 2.5g port on the router, but then anything hardwired is capped at 900-something MBPS.

I don't know if I should run the modem 2.5ge straight to the router first, then to the switch? Or to the switch, then back to the router… Or am I screwed or limited by the hardware somehow? Should I run a cable from the S33 modem's 2.5ge port to the router's 2.5ge port and then run another cable from the S33 modem's 1ge port to the blue "WAN" port on the AX11000 router?

I could care less if all Wi-Fi devices were capped below 1000 mbps / 1gbps as long as I could have at least my own desktop PC device able to get over 1000mbps when hardwired especially.

Hey all! I almost forgot about this thread/post/forum from a year+ ago. Figured I'd circle back with new info. Well, not really new info. But ironically enough, I recently started "IT school", let's say. I am attending a school/program to get some IT certs and hopefully a job in the IT world. I've always been into computers, but never worked in the industry. Home project/hobbies and having troubleshooting issues like the one in this thread only encouraged me to try and learn computer networking in a professional capacity. I'm drinking from the firehose but trying to soak it all up like a sponge. I obviously don't know what I'm doing just yet, but hey. :cool:

I noticed this thread has the highest views of any similar issued questions/posts on this forum, but never any replies or solutions lol. FWIW, I'm still in the same boat: having a 1200+mbps speed package/plan yet cannot access speeds of over 1000mbps almost ever. In fact, I'm currently in the midst of a slightly new troubleshooting situation that involves the topic at hand. I noticed my wired ethernet speed tests are worse than they've ever been. I even completely bypassed the ASUS ROG router in question to see if I could isolate the issue. In the past, if I was to plug directly from the ARRIS S33 modem into my desktop PC (Realtek 2.5gbe motherboard port), I could easily achieve download speed tests in EXCESS of the 1200 MBPS plan I have. However currently, I can barely crack 600+ mbps speeds when connected directly. So, something is seriously amiss. Spent about an hour on the phone with Comcast Xfinity tech support today, which was another total waste of my time. Lots of restarting this and that (computer, modem, etc). It's really frustrating when they're asking you to like, "Please sir can you kindly unplug the ethernet cables and plug them back in and make sure they are tightly connected sir please thank you" when this is probably the least helpful idea :mad:

I have an appointment for a field technician to come test the lines tomorrow. At least, I hope that's still on the schedule. Because I received some confusing automated call message after my tech support phone call(s) with India that said "Hello this is Comcast We are calling to advise you that our technicians identified and corrected and issue related to the service problem that you reported If your services are restored" - which wasn't and isn't true lol.

I even tried picking the brain of my CompTIA Network+ instructor, but TBH I don't think he understands what I'm asking or cares or wants to help (not his job description lol). So that was a dead end.

I hope that as I make more connections in the IT world, I can figure crap out like this myself and help others. Currently I'm wondering if I'd benefit from getting a "better" NIC card i.e. Intel X550-T2 2-Port 10GB Ethernet Converged Network Adapter. I'm still not sure why or how it'd be helpful in this scenario of not being able to get those elusive 1200mbps speeds down, except that from what I read Intel makes some of the best NIC cards/adapters and generally have good driver support vs Realtek. But what do I know? I know nothing Jon Snow.

I have also thought about a different router entirely. You'd think the beast of the ASUS GT-AX11000 would be easily more than sufficient for the task at hand, but perhaps not. Perhaps I need not one but TWO 2.5gbe ports on the router? And/or, maybe I need a different modem that supports Link Aggregation? I foolishly got the SURFBOARD Arris S33 and sold my previous Surfboard SB8200 that DOES support Link Aggregation up to 2gb! Once again, an upgraded "better, newer" version of a product line that is simultaneously a downgrade lol. If you ever wondered about how ASUS makes money!? lmao

The GT-AX11000 has 1 2.5 Gbps port. It can not pass 2.5 Gbps speed to any Ethernet device because of this as the rest of the ports are 1 Gbps ports. (You can use the blue Ethernet port as a LAN port). You'd need one of the ASUS routers with at least 2 2.5 Gbps ports, so you can connect the 2nd port to your TP-Link switch and pass the 1.2 Gbps speed. I don't have a list off the top of my head but the GT-AXE11000 is out. The choices: GT-AXE16000, a Zen WiFi Pro ET12 (they sell them 1 piece for $479), GT-AX6000. If I think of any more I will update.

EDIT- Per a Dong Knows Tech article I have mixed up Zen WiFi Pro ET12 with XT12. They are two separate models! Both are tri-band but the ET12 has one each of 2.4 GHz, 5 GHz, and 6 GHz, vs XT12 which has 2.4 GHz, 5 GHz-1, and 5 GHz-2. (Gotta thank him with a comment on his blog)!

The RT-AX89X can be used if you are going to move up to 10 Gbps (ONLY) because the 2nd 10 G port Is SFP+ which only supports 10 Gbps speed, not 5 Gbps nor 2.5 Gbps. You'd need a SFP+ to 10 Gbps Ethernet adapter and 10 Gbps port on switch like QNAP I believe, or SFP+ port (10 G) on a new switch...

As I'm more or less just responding to myself at this point, at least it's sort of a working document of troubleshooting and finding solutions lol.

Luckily had my line checked by field tech with my ISP, got 1400mbps down 40 up. Modem is working fine as well. Bottleneck is the router. Now that I know more about the hardware and networking behind some of this, I wish I wasn't such an idiot purchasing the GT-AX11000 thinking it'd allow me to achieve greater than 1gig speeds on all devices. In fact, it won't even let me achieve 1gig or above speeds on a single device lol. I think I realize now ASUS was curiously deceptive or confusing with the marketing or advertising of the 2.5gbe port on this router. I guess if you wanted to use it for local NAS or something it'd be capable of that. But to pass along a 1200-1400mbps speed from the ISP to anything else? No can do.

What I know understand, or think I understand.... is that once you take that ethernet cable from the modem (that's tested/confirmed speeds at well over the 1.2gbps Xfinity plan) into the ASUS GT-AX11000, you're capped at 1gig no matter what you do. If you run the ethernet from the 2.5gbe port on the modem to the 2.5gbe port on the router, even if you plug a direct ethernet cable from router into your desktop PC for example (with a 2.5gbe Realtek on-board NIC), you're still capped at 1gbe no matter what.

Like an idiot, I spent good money on the GT-AX11000. That kind of money SHOULD in theory get you the best tech available at the time. I'm not sure if there were other routers available at the time of the GT-AX11000 release that would have been capable to solve this problem or not but now I know there are. Or at least I think there are. For example, the ASUS GT-AX6000 advertises "flexible network ports functions" i.e. DUAL 2.5g ethernet ports! You'd think that would solve this problem and be able to give my hardwired desktop PC the full speed I'm paying for while also broadcasting that signal speed over wifi to any devices capable of utilizing it as well. Here's a cool picture:


That's not cheap, but neither was my AX-11000 a year and half ago. Maybe I could sell my current AX11000 for the AX6000 which sounds/seems like a downgrade honestly, but it's not in this use case scenario anyway.

A potential workaround I'm exploring in the meantime? ....

I'm really curious to see if this would work... could I use the USB 3.0 port on the GT-AX11000 as an OUT via this adapter ethernet back into my PC?

Just an FYI I see two places B&H Photo Video and Amazon both selling the GT-AX6000 for $329.99 right now. I think that is your safest bet to accomplish 2.5 Gbps through to your switch and be able to distribute it to your computer plus 3 other devices. (via your 5 port 2.5 Gbps switch).

(I did check the specs on your TP-Link switch and it doesn't show 802.3ad support which is link aggregation)...

I looked into it some for my own edification. It does look like it takes a managed switch to use link aggregation, when it's a link to a switch. If it's a device to device link and both devices support link aggregation, obviously it doesn't need a switch.

Are you sure the S33 does not support link aggregation? If it does support it, then connect the two Ethernet ports on the S33 to your AX11000 for WAN aggregation, (use two exact same spec cable. I believe once you go to the setting in the router pages it will tell you which ports to use). Then use the 2.5 Gbps port on the AX11000 to your 2.5 G switch, and switch to computer...

Let us know how this works out...

I also want to know how it works.

Level 7

I know this is an old topic, but if you want 2.5Gbps internet, you're going to need a router with a 2.5Gbps WAN port, that's simply how "routers" are built.
One option, if you want to keep using your GT-AX11000, is to use it as an access point and use a raspberry pi or so as your routing device.
Personally, I use a NUC 12 with a pfsense router/firewall (proxmox VM). You can add various high speed ethernet ports via thunderbolt or use the built-in 2.5Gbps port. My Asus router has been converted to a simple access point for the exact same reason.
Your switch can be used to add other highspeed ethernet ports to your backbone, it's not a total waste...

I've seen someone here use an ASUS USB-C2500 plugged into the USB 3.1 port to free up the AX11000's 2.5 G port, which in this particular case I would run to the 2.5 GbE switch...