Showing results for 
Search instead for 
Did you mean: 

GT-AXE16000 Poor Ethernet Performance

Level 8
Hi all - I've done quite a bit searching on this topic, but haven't found a fix. I'm hoping that someone here can offer an assist!

Current setup:
Internet: Xfinity, 1200 down / 40 up
Cable modem: Arris S33
Router: GT-AXE16000

The main issue I'm seeing is very mediocre and unstable Internet speeds when connected via Ethernet (currently 10G Port, but I've tried other ports as well.)

In speedtests (, Speedtest app to local Comcast server), speeds start fast (just over 1Gbit) then immediately drop somewhere between 300-500Mbit before recovering a bit. In comparison, if my laptop is connected either directly to my modem or even to the 5GHz Wi-Fi network, I don't have any speed issues whatsoever and typically test around 1250-1300Mbit. I've actually noticed my gaming laptop typically speedtests faster with more stability on the 5GHz Wi-Fi network (160MHz channel) than it does Ethernet, which is both exciting and disappointing at the same time.

QoS is off, AiProtection is off, I've attempted switching the WAN port to one of the 10G ports, and I've factory reset it at least once in an attempt to fix the issue. No joy.

I did see a review from Tom's Hardware talking about slow Ethernet performance with the GT-AXE16000... If this isn't fixable, I may just switch over to an ET12 mesh system for my home rather than utilizing the GT-AXE16000 as my primary.

Thanks in advance!

You may need to manually release the IP lease from the ISP.  Another possible work around is to clone the MAC of the previous router.  (A couple things to try if you haven’t already).

I will see that message every now and then and yesterday, during that testing session, it happened.  Rebooting the Modem seemed to fix that.

Are there any special settings with Xfinity being your ISP?  Are you needing to clone a MAC address or anything like that?

I will be looking for situation regarding Xfinity to see if anything pops up.  I have already found a thread regarding using a Static IP address and MAC cloning.  I will assume you have your Gateway in bypass mode.

Maximus Z790 Hero,
Intel i9-13900k
Intel BE200

Also, don't forget to set up the IPv6 configuration.

Maximus Z790 Hero,
Intel i9-13900k
Intel BE200

Level 8

Some good news and some bad news...

Good news is the DHCP issue was absolutely on the ISP end and everything worked the next morning. Bad news is I'm still seeing WAN data transfer speeds being inconsistent over Ethernet, something I don't see when I use a different router as my primary. Starting to think it's just how this model is and I'm ready to give up on it.

After a month of testing the crap out of multiple GT-AXE16000 units, I'm a bit burnt out and ready to just move on with the "lesser" device that doesn't have these issues. You've all been wonderfully helpful and hopefully it's just my bad luck or something incompatible on my end between my hardware and this specific router.

Level 7

I read elsewhere that the AXE16000 has trouble transferring data from WAN to LAN on the 10Gbs ports when the traffic analyser features are turned on. I have a 3Gbs Internet service and was having issues with the speed test on my MacBook Pro being around 400-500Mbs slower than the speed test on the router which was receiving the full speed. Turning off all the traffic analyser features 'fixed' the problem for me.