Showing results for 
Search instead for 
Did you mean: 

GS-AX3000 Crashes When Connected Device Looses Power

Level 8

Ever since I got my GS-AX3000 with the latest firmware, I have had a problem whereby the router crashes when I turn off my Vizio Smart TV which is connected via ethernet. I originally started discussing it here. I have reported all this to Asus with detailed logs and such, to which I have never gotten a serious response - just telling me to reset the router - which is not helpful as this is a null pointer error and that is clearly a programming problem that must be fixed in firmware.

Note that there is no crash if I simply remove the ethernet cable from the back of the TV. Only when the TV is powered-off while the ethernet is connected!

Anyhow, I decided to try a wifi connection in place of ethernet and the problem does NOT occur. This makes sense to me given what I have seen repeatedly in the log files. But going back to ethernet (regardless of which port is used) brings the problem right back. Since use of wifi for this device is not desirable in my case, I really need to get ethernet working without crashing.

Given that the issue seems to happen when the TV is turned off (it does not completely loose power, it just goes to a sleep more, I think), I wondered what might happen if I kept power applied somehow. So I tried putting an old Netgear ethernet switch between the TV and the router. The switch is powered, of course, so even if the TV is shut down, the switch is still powered. Doing this demonstrates that with the switch in place, turning off the TV no longer causes crashes. This does something to confirm my theory.

I then decided to see what happens if I leave the switch connected to the router and simply pull the switch's power plug. This immediate caused a crash. And in all cases, the log file looks basically the same. This confirms my theory with what seems to be pretty conclusive evidence that the problem is inside the router and NOT specifically a consequence of using this TV (or likely any other specific device).

Given my results, I cannot help but wonder why I have not seen many other posts about this issue. So I wonder if others with this same router (and possibly other routers using a BCM6750 CPU) can replicate this on their systems? Near as I can tell so far, it only matters that a connected device is powered and that the problem arises when power to that device is removed (perhaps suddenly rather than a more controlled power-down as in a clean PC shutdown).

So I wonder if others could try this sort of thing with their routers and post back here what they find? If enough people can replicate this and complain to Asus, perhaps this will get fixed sometime before I am dead!



Level 12

I noticed you left out the specific firmware version you are on, so I went to the ASUS website (USA) and found the latest firmware is a 386 dated 2021/8/17.  (This router does seem somewhat neglected regarding firmware development).

It does seem that this sort of error (NULL pointer) is occurring when updating from 386 to 388 but that is not available for the GS-AX3000.  (I am not a programmer by trade).  I do have a few items connected directly to my AXE16000 and have cycled them ON/OFF with no such effect, nor with the prior AXE11000 (which is now a node).

I suspect a WOL issue, have you tried tinkering with the setting?  (I have my networking backbone on battery backups, more specifically battery backups with LiFePO4 replacement batteries on most, meaning power hardly ever goes out.  WOL is not enabled).


Hi and thanks! I think I mentioned I am on the latest firmware. It is and this is how the unit was delivered to me from Amazon. I have checked regularly (both from the router's admin pages and from the Asus website) for something more recent. I had not considered using something older until now. I see there are versions and

Thanks for testing on your unit and reporting back. I am not sure where/if there is a WOL setting anywhere in the router's pages. I find WOL in the Tools but there is nothing I can set there. I know that WOL works on my LAN as I do use it now and then (never with the TV though). Perhaps you can point me at something? Maybe I need to get at it via SSH?

I am retired but was a software engineer for over 30 years. So I know what a null pointer error is. I do not have enough information to read the stack traces the router kindly puts in the crashlogs. But I know that it happens at the same address ever time. And I know I can replicate it easily now. So someone at Asus should be easily able to isolate and fix this (if they are properly motivated).

I too keep my network backup on an APC battery backup (lead acid but I know about LiFe and would be interested in how that works for you in your backup). Perhaps a PM? But this is not related to my issue here as the TV is not fully powered off when these crashes happen. It offers an "Eco Mode" and a "Quick Start" mode for power. I always have used the latter as the former does not permit the TV to turn on from the remote. I have checked, however, and turning the TV off in either mode causes the same crash in the router when connected via ethernet.



Does anyone know if something like a POE Switch could be used in between the router and the TV to avoid this problem? I read a little bit about POE and know enough to know I know nothing. I don't feel like additional hardware should be needed to fix this issue. But putting a powered switch in seemed to handle it. I just do not want to have to power something else. So maybe a POE switch would do it? Thanks

My wife got some sort of PoE device from her work with a MacBook a long while back.  I’m honestly not even sure the setup the way instructed to connect even needed it.  (I hate it because it is very warm/almost burning hot to the touch.  I feel like it is wasting a lot of electricity.  Since she is in the medical field and I also never dealt with PoE I just tried to keep it connected exactly how instructed, but eventually I think the wires/Ethernet cords got mixed up and it didn’t even work anymore, was just connected eating up electricity.  I eventually just unplugged it.  The old switch you tried is it too slow?

A couple of questions:  Did you try the hard reset?  How about a different Ethernet cord?  When my son received his new MacBook Pro this year we spent a tad over $3k even with his student discount.  My wife and son dialed Apple Tech support and handed me the phone (basically forced me) to talk to them.  The agent immediately had me press the reset button, (which did not work until the second press), wiping out my entire network.  While I was really gumpy over that it did seem to help repair some of the issues I was experiencing.

ASUS produced an English manual for the GS-AX5400 you can go to it’s support pages and get one.  I assume it is basically the same as yours and I read through it twice looking for WOL but did not find it.  I did not have a chance to look at the Specs page to see if it lists WOL (we are out of town until Sat night)…

The LiFePO4 replacement batteries seem to work a lot better.  I say seem because the old PbA were completely dead by the time I replaced them.  I started with PbA replacements then decided forget it spend some extra for the LiFePO4.  (I have 4 of them for various vehicles in the household, started with that application).

I remember when COVID was a big problem early on that some big manufacturers were asked to switch to producing masks (PPE).  Somehow (I suspect) ASUS has been switched to defense products…

After reviewing a diagram of ethernet cable pinouts, I checked the cable I was using. It has only 4 conductors in it (so an older, 10/100 Mb/sec). And I swapped it out for a clearly marked, CAT 5E cable. Since then, there has been no crashes. Still a bit early to be sure but initial signs are positive! I have a hard time understanding how a device's power on/off condition would impact the router via any ethernet cable (no matter how many conductors). The 2019 TV seemed to run just fine with the old cable and the router reported the connection as 100 Mb/sec (which is still the case with the new cable). But I do not expect it to do 1G/sec as the wifi support on the thing is limited to only 2.4Ghz (or at least it does not show me my 5 Ghz in the list of SSIDs). My limited testing so far indicates that this might be (at least part) of the problem. I will do more TV watching and see if the thing crashes any more.

A PoE switch shouldn't make any difference, as neither the router nor the TV are PoE devices (PoE is passive until it detects a PoE powered device).  An basic hub or switch would provide basic isolation between the 2 devices, and should make the change of link state invisible between them.  Equally, a 4 conductor cable vs 8 conductor makes no difference for 10/100 (for the standard 100 base TX), if it's at least Cat 5 and certainly shouldn't cause a reboot.  One possibility is that the cable was actually Cat 3, or voice grade, which is only suitable for 10 base T and some failed 100M standards that essentially don't exist today.  There were other 100M standards that did use 8 conductors, but those also failed and essentially don't exist today; they wouldn't work at all on a 4 conductor cable, or would fall back to 10 base T, I believe.  There shouldn't really be many Cat 3 cables around these days, although some corporate and telecoms wiring closets might still have some old stuff.  Even so, a Cat 3 cable shouldn't be the cause of a crash, just corrupted Ethernet frames.

There's really nothing that should let your TV crash the router when it powers down.  That sort of thing really just doesn't happen with Ethernet.  The Ethernet interface on the TV would have to have a really weird design fault to do it, I reckon.

Thanks. I knew I wasn't understanding the PoE thing. Now I really know 🙂

I agree that in my long experience, I have never seen any time that a link state change would crash a router. It never happened on any of my earlier routers (Netgear R6400 and R7000 plus an old Asus RT-n12). As the crashlog clearly and repeatedly showed a null pointer as the same exact address as the cause of the crash, this is clearly a programming problem fixable only by firmware update. It is most certainly NOT the TV's fault (although I have many other reasons to hate Vizio since buying this thing). If things stay stable with the new cable (man, that rhymes!) I will notify Asus. Cheers

Level 8

It was too good to last! Even using a marked, cat 5e cable the router crashed again when I turned the TV off last night. I had not noticed any crashes in at least 2 weeks so I had hoped I had this licked. Looking at the crashlog, it is the same thing: null pointer at the same address. So I guess not 🙂

When I started networking fast was 100 Base T, full duplex.  At that time switches had dedicated uplink ports and you had to be careful with crossover cable vs patch cable.  (IIRC you could see the crossover literally where they terminate at the RJ-45 plug).  Yes I have seen switches error out and just not work depending on the cabling.  I remember running Cat 5e cable through our old house, manually setting up IP addresses before I even learned of a DHCP server.  Nowadays it's all auto detecting and it's just a matter of checking that the cable spec is up to par.  I'm surprised at how thick they are getting especially the Cat 8 ones I've been buying of late...

I can't help much because I don't have an GS-AX3000, but I hope there's a new firmware release that addresses your issue...