Showing results for 
Search instead for 
Did you mean: 

Defective (Probably!) ROG GT-5300

Level 7

      I have had this router since 2018 and it has worked great. I would say it has been the best router I have had. The other day it would no longer detect my internet connection from the modem. Swapping the cable did not help. At first I thought our modem was the problem, but our internet worked fine with an old router I had lying around. No matter what I have tried, the internet indicator light on the router stays red. I have tried a factory rest about four times, but the only time it actually worked was doing it from the router only. The software would not reset it, even though it appeared it was doing so. I have tried updating the firmware using a firmware file I downloaded, but it does not update, even though it looks like the process finishes. The firmware on it is 3004.384.XXXX (Sorry I do not know the last 4 digits). After the firmware update finishes, I log back into it, and it does not change.  Trying to have the router look for a firmware file from within the utility does not work. It just tells me it cannot find the update server. It is supposed to upgrade to 3004.386.XXXX.  I have already replaced it, but would like to hang on to the router as a backup. Any ideas?? Thanks for any and all help anybody can provide!


Level 13

ASUSwrt can’t contact the server with no WAN/internet service that makes sense (but I would have tried as well).

When you manually upload the latest firmware:  once it says completed, use the power switch/button on the router and turn it off, basically the first step to hard reset.  Hard reset it:

Thanks, but I tried that. Just did it again just for the heck of it, and the firmware version is still the same. The router did reset as all the settings went back to factory.

As I understand you have a new router in place.  Not knowing much beyond that have you tried connecting the WAN port to a LAN port on the replacement router?  (To see if it’s just a problem between the modem and the GT-5300).

I have not tried that! Will give it a shot this morn and let you know how I make out! Thanks!!

Level 7

Connected the defective router to a LAN port on the new one from its WAN port, same thing. Red light stays on showing no internet access.  In my humble opinion, the WAN port on this thing is bad. I am not sure if there is a way to repair it, or if the unit can be used for something else. I looked for 3rd party firmware for it and came up blank! On a side note, having to verify EVERY time I try to post something using the recaptcha is a pain.  😵

Regarding the forum I vaguely remember a Captcha, BUT if it makes you feel any better there was a period where I could log in but could not post!  The only thing I could do was send PMs!

When I first started building an AiMesh I didn’t know how to connect the nodes properly you can connect LAN to LAN IIRC, a glorified switch.  I was hoping that a WAN setting went awry but yes sadly seems like your WAN port went dead.  Still wondering why the newer firmware does not install.  You’re not the first to complain about that.  Seems like one beta firmware bricked an GT-AXE16000 which I have.  While my son is away I have flashed the latest beta with my fingers crossed!