cancel
Showing results for 
Search instead for 
Did you mean: 

Creating a Guest WiFi with VPN breaks LAN1 on GT-BE98

xazac
Level 9

Hello, I'm having a problem with Guest Network Pro that doesn't let me use VPN Network.

My main WiFi network is called "Private - WiFi" and it has a WPA2/WPA3 Personal security. This main WiFi network uses Smart Connect with all bands.

A week ago I created an IoT Network called "SmartHome - WiFi" for all my WiFi smart devices with "Use same subnet as main network" option and it works like a charm.

Now, I need to create a new network through Guest Network Pro by selecting VPN Network but once I created the profile, LAN1 stops to work: IP address obtained through this port becomes 169.254.x.x and the device attached can't connect even using static IP on the attached device itself.

*ALL* other WiFi and LAN devices works perfectly, the bug only affects LAN1.

Anyway, once I activate the VPN switch inside the Guest Network Pro setting, the main WiFi stops to work: whenever I try to connect to it, it keeps asking for the password and it won't let me connect any device to main WiFi. The only way to get main WiFi to work again is to turn off VPN switch in the Guest Network Pro settings.

I tried to change the default VLAN ID assigned to that network from 52 to 520 but LAN1 still doesn't work.

I also tried to delete that network and to create a new one, but I still have this issue.

I already called ASUS Technical Support but they weren't able to help me.

Firmware version is the latest one: 3.0.0.6.102_33570

Any help is appreciated, really thanks!

216 Views
3 REPLIES 3

Saltgrass
Level 13

Could you tell us which VPN provider you are trying to use?  I could try to set one up to see how it works.  The last time I used a VPN, it was a dial-up to the company. 😁

Maximus Z790 Hero,
Intel i9-13900k
Intel BE200

Hello @Saltgrass,

Thank you for your reply!

At this time the VPN provider is irrelevant since the issue starts before to create a VPN profile into router VPN settings page.

I edit the first post in order to provide more infos about this issue.

Thanks 

If you saw the other message I deleted, the setting on the WAN - ISP special requirements shows VPN + DHCP.  I still don't know what it does, but you might want to try enabling it.

 

Maximus Z790 Hero,
Intel i9-13900k
Intel BE200