Showing results for 
Search instead for 
Did you mean: 

Can't change 5Ghz second channel settings on GT-AX11000

Level 8

I just got two GT-AX11000 routers, and am having this issue on both. I did update them to the latest firmware as the first thing before setting them up. If I go to the wireless settings for the 5Ghz-2 channel, when I try to save, I get a console error (I've tried different browsers which all get it but this is from Chrome):

Uncaught TypeError: Cannot set properties of null (setting 'value')
at applyRule (Advanced_Wireless_Content.asp:1105:48)
at HTMLInputElement.onclick (Advanced_Wireless_Content.asp:3063:95)

Of course I could drill into it for even more info, but it doesn't mean much to me. Applying settings on the 2.4 and the 5Ghz-1 channels are fine. During setup I used a weak password just to check some things out quickly, but was unable to update it for that channel. Only by resetting to factory settings, and doing everything again, was I able to enable Wi-Fi6, or change my password. I'd still like to hide the SSID on them but there doesn't seem to be a workaround for that even with a factory reset.
Is this working for anyone else? If so, what browser/OS are you using? Or if this is a known issue, please let me know as well! Thanks! 


Level 7

I have encountered this same issue with  I reverted to the previous version and everything works fine.

Level 8

I'd just like to know if this is a recorded issue and can hold out until the next firmware, or if I'm gonna need to revert and stay there. My only current issue is broadcasting an SSID that I don't want to, but I can live with that until a new FW. Just stinks if I ever need to change anything else at all about this channel I gotta factory reset for now, and enter it during initial setup.

Level 13

Maybe you can try to set it to another channel to observe if any improve. 

@ahfoo wrote:

Maybe you can try to set it to another channel to observe if any improve. 

I don't understand what that has to do with this, I think you may have replied in the wrong thread.

The problem is that I CANT change the settings, so I can't change the channel, and don't need to. The performance is fine, the issue is that no settings on the second 5ghz channel can be changed from the menu on the newest firmware. I'm not having any performance issues, my issue is with the ability to change any setting on the second 5ghz network.
I'd just like to know if this has been acknowledged by anyone at ASUS.

This is a bug, in the web interface, that prevents you from applying any settings changes to the 5Ghz-2 channel. Can't change channel, password, SSID, Wifi6, ANYTHING - Can anyone confirm if this will be corrected at some point or is at least acknowledged as an issue? I have it on two routers, and someone else confirmed that they had to change to the old firmware in order to manage their 5.0Ghz-2 channel as well.

this is exactly the issue (2.4 ghz and 5ghz-1 band is fine, 5 ghz-2 band has this issue)i am encountering that lead me to this forum after googling. tried all sorts of browsers, power cycle etc, doesnt work. short of doing a hard reset, but that didnt seem to work for a previous user in an earlier post in this thread. I created a ROG forum account just to reply. so it seems it's a firmware issue


furthermore, i have also been getting weird drops in 5ghz  connectivity (not limited to one location in my home), the signal will lose internet connection then cease broadcasting , and then after awhile it reconnects, happening since this previous firmware (not sure of exact occurance date but probably since early 2023

Level 13

I just check and confirm I was able to change with the last firmware with Can you explained more or provide if you selected the field in Wireless tab for 5Ghz, you cannot select or anything?

Level 13

I meant for the 2nd 5Ghz wireless radio.

Level 8

Here's a video link. In this I show:
- 2.5Ghz second channel, even with no changes (I refresh the page first), gives a console error when you apply changes
- Attempt to make a change, same thing happens, after refresh, the change is gone (the 'applying settings' never goes away, I've waited 10 minutes before)

I've got 2 of these routers, same on both, and have tried from 5 different PCs as well as Chrome, Edge, and Firefox, all with the same results.
I'm using the latest firmware. Given the first reply to my post, I'm not alone here.

Level 11

Since you noted you tried a hard reset, maybe try the ASUS Router ap?