Showing results for 
Search instead for 
Did you mean: 

Asus GT-AX11000 with Moca Backbone and Switch

Level 9


I own a GT-AX11000 router and a pair of XT8 nodes, which I’m currently using hardwired through a Moca setup. 

My current setup is: Cable modem >> Asus USB-C2500 >> GT-AX11000 USB Port >> GT-AX11000 2.5Ge port >> Moca System >> XT8 2.5 Ge port >> Computers

When used with the config above, all works wonderfully well, Internet connection is stable and I can get my full 1.2gbps connection on the nodes if I test multiple clients (cannot get 1.2 gbps on a single client because the ports on the XT8 nodes are Gigabit).

Now I’ve purchased a 2.5Ge Switch to add to the system between the Moca system and the XT8 so I could get the full 2.5Ge on a specific computer on my network, which is a Mac Studio with a 10Ge port. When I plug the switch and the Mac to it, I get a connection, but frequent drops in the Mac. The XT8 works, but the Mac, on which I work, gets disconnected very often. Disabling the network card and reenabling it brings back the connection, but it drops again in a few minutes.

The new setup is this:

Cable modem >> Asus USB-C2500 >> GT-AX11000 USB Port >> GT-AX11000 2.5Ge port >> Moca System >> 2.5Ge Switch >> MacStudio and XT8 2.5 Ge port >> Computers

I’ve tried two different 2.5Ge switches with the same results and also tried setting a manual IP address to the Mac, also with no improvement.

What could I be missing? Or is it a non supported setup? It seems like the Mac is recognized initially, but then something causes a conflict and the network connection starts failing.

Thanks in advance!


Accepted Solutions

The MacStudio connection has been stable and full speed to the MoCA system/AX11000 router ever since the new switch was installed, so I am marking this as resolved.

Thanks for the help!

View solution in original post


Level 14

Can you connect the MacStudio to the MoCA directly to see if it’s stable?

@jzchen wrote:

Can you connect the MacStudio to the MoCA directly to see if it’s stable?

Thank you for the response!
Yes. It's perfectly stable. If I plug either the Mac Studio alone or the XT8 alone directly to the MoCA adapter or alone in the Switch (along with the cable coming from the MoCA adapter), they work fine. Problem only happens when both of them are plugged to the switch, along with the MoCA ethernet cable.

Do you happen to have two switches with you?  The reason I ask is because (I did not know this), but I read somewhere that the speed is pulled down by the slowest device on the switch.  So if you have your MacStudio (which supports up to 10 GbE) but have a 1 G PC the MacStudio speed will be pulled down to 1 G.  It was really hard to believe but someone on that thread confirmed it, and seems like you are seeing the same thing.  So ideally connect another 2.5 G switch and then all the 1 G devices to that:  MoCA - MoCA - 2.5 G switch - MacStudio, 2.5 G switch (maybe 1 G switch works I don’t know) - PCs, etc to the 2nd switch.  See if that works…

I did test with a second 2.5Ge switch, which I have already returned, however the issue is not really that I'm not getting full speed. I do get full speed on the Mac when it works (Speedtest returns the full speed on the Mac when plugged in directly to the switch along with the XT8 and the MoCA adapter). The main issue is actually the very frequent connection drops that are happening in the Mac when plugged in to the switch along with the XT8. Pardon me if I didn't get the point of this test, but just trying to understand if really needed. The frequent drops also happened with the second switch.

Point taken I agree the XT8 is basically a second switch that I was hoping to try.  (Just curious is this AiMesh or set up as Access Points)?

Anyways I did find something maybe worth a shot.  The XT8 has two hardware versions, 1 and 2.  And strangely there are two BIOS, exact same, but one for version 1, and one for version 2.  Maybe try manually flashing the two with the appropriate version.  Also please verify the GT-AX11000 is also up to date, on (conveniently for my memory)

I appreciate the quick turnaround. The three nodes (AX11000 + 2 XT8s) are connected as an AiMesh.

The attached picture shows my current firmwares, which were all done OTA through the router admin page. Should I be worried about the Hardware Version in this case and really upload the firmwares manually to the XT8 nodes?


That’s a good point and I am definitely puzzled.  If I understand correctly the Mac works fine directly connected to the MoCA, and also works fine if it’s the only thing connected to the switch?  If this is true the culprit I suspect is the XT8 you are plugging into it.  What happens if you use a 1 G port instead of the XT8 2.5 G port to connect to the switch, (just for curiosity does the Mac connection stabilize)?

Mac works fine connected directly to MoCA adapter;

Mac works fine connected to the switch, which is connected to MoCA adapter;

Mac works fine connected to the XT8, which is connected to either the switch or the MoCA adapter;

XT8 works fine connected to the switch or the MoCA adapter;

The issue happens when the Mac and the XT8 are both connected to the switch at the same time, no matter what port I'm using on the XT8.

I may be wrong, but I believe the issue is with the AX11000 recognizing both the Mac and XT8 at the same time on the other end of the MoCA adapter.

An update:

I went ahead and ordered a managed 2.5Ge switch from Amazon (Sodola brand - had good reviews), which arrived yesterday afternoon and it's been stable throughout the day today. Will keep testing for longer during next week and let you know if the problem is gone.

FWIW, the original 2.5Ge switches which were not compatible were these:

Real HD 8 Port 2.5G Ethernet Switch Unmanaged Network Switch with 8 x 2.5 Gigabit | 1 x 10G SFP+
keepLiNK 5 Port 2.5G Switch Unmanaged, Ethernet Switch with 5 x 2.5G Base-T Ports, 1 x 10G Base-T SFP Slot

I don't think the switches were defective or bad quality as I see good reviews for them as well, but maybe the Mac was picky on something they did and this new one does not do.