Showing results for 
Search instead for 
Did you mean: 

anyone using GT-AX11000 without issues?

Level 10
hello just wanted to ask if anyone used the ax11000 without any issue for more then 6months here?
are you turning on the ai protection features?

i have use 2 ax11000 already they have the same problem, after a few months like 2-3 months i need to keep factory reset for it to go back to normal
its like a memory leak problem

I can understand your pain. I remember back when the internet was dial-up. Back then the old browsers were slow. I can't even remember the name of my favorite one now sadly but it would download the links first before any images, so one could keep clicking through real quick if you needed to get somewhere fast. But I reminisce....

If you are concerned about the ASUS router being an issue I would honestly suggest you buy a different brand and see how it goes. I initially got a Linksys Hydra AXE6600 from Costco. Good thing about Costco is their return policy. So try it out for as long as you wish I'm not even sure they have a time limit on returns. (Someone please correct me if I'm wrong)? The only downsides to that router was it did not handle my Ethernet loop with grace and did not have a USB port.

I am very weary of large ISPs that want you to use their routers and am so grateful we are with a small one called "Giggle Fiber" that only serves two cities here as far as I know. I feel like I trust them to not mess around with my service...

Call tech support with (what you plugged in directly which worked), and router. Swap them during the call, then clone the MAC and plug the router in. It's one of my (religious) beliefs not to lie, but I'm afraid it's one of the few times I've tried, in the past with Ch*****.

I can't promise you that you are correct that it's the ASUS router, especially if everything works fine for weeks on end then all of a sudden....

Level 7

I have the same issue it’s really bugging me