cancel
Showing results for 
Search instead for 
Did you mean: 

Anyone know if the next BE98 Pro firmware upgrade is going to enable support for WiFi 7 MLO?

Saltgrass
Level 13

The Windows Insider forum has just released a new build which includes support for WiFi 7.  In order to see those options, a compatible system is necessary, so a new firmware is required to make the BE98 Pro compatible.  It would be helpful, if even a Beta version could be made available.

Thanks for reading.

Maximus Z790 Hero,
Intel i9-13900k
Intel BE200
9,067 Views
150 REPLIES 150

Upon 1st or 2nd reinstall I did see some strange "Unknown" SSIDs populate the Guest Network Pro or MLO pages.  I just deleted them.  Eventually 4th or 5th reinstall they stopped showing up.  I switched to beta a little while ago to see if there was any improvement in speed on the new to me OnePlus Open but improvement was negligible, so I moved back to the regular firmware when my son returned home.

@DorR Bet you have no interference on that upper 6 GHz band huh?

@jzchen @The upper one is my private ban😉😂

I hope asus will release a new FW soon

@jzchen When you setup the network profile in the MLO section, do you use your normal Network name or make up a different one and use that?

It seems, when I use a different name, is when I get the additional networks.

Maximus Z790 Hero,
Intel i9-13900k
Intel BE200

For the MLO section my list is currently empty.  I toggle the MLO switch OFF then ON.  It then asks specifically for a WiFi 7 SSID and (Legacy specific) IoT SSID.  Since I have many devices on older WiFi I specify different SSID_MLO and then my original SSID for the remainder of devices to automatically connect with original credentials...

@jzchen Since I have reset the router and set it up, as suggested, the Beta firmware has been stable.

One thing I notice is, the IoT network is WPA-2 Personal and I don't see a way to change that.  I have a multi-function printer that only does WPA, so I did not think it would connect, but it did.  The problem with that is, after a short time, the House Alarm system was kicked off the IoT network, so it started beeping at me.  Maybe there should be a WPA option on that IoT network, for those who feel safe using it.

I still cannot say for sure the MLO is functional, but I am seeing higher link speeds being shown in Windows 24H2 than I see in the current Windows 11 version.

Maximus Z790 Hero,
Intel i9-13900k
Intel BE200

That is a tough situation.  For me I would have liked the option for WPA2/WPA3.  But if your home alarm needs it I fully back your request for WPA support. 

I am on yet another BIOS version, starting with 3, but I was specifically asked not to share it yet.  (I just sent a message asking if I could share it now).  When I installed it things were terribly buggy so I first turned MLO OFF,  then I also turned "WiFi 7" OFF on 2.4, 5, and 6-2, SmartConnecting those 3.  I left 6-1's WiFi 7 ON.  I still have the IoT network, with all 3 of them having the exact same SSID.  (This is in Access Point Mode with AiMesh).  Speed in my room on my new phone got so terrible, I ended up enabling Ethernet Backhaul Mode.  I'm still not impressed with the speed.  It could be my phone/phone settings I guess...

I ended up splitting a TP-Link Deco BE95 2-pack with a friend, ALSO to a world of disappointment:  6-2 is not usable beyond backhaul.  Since we each have one that means we each basically have a BE85 in BE95 clothing.  Speed is terrible on my new OnePlus Open phone, although better on MLO, when connected to it...

can you show us picture web interface where its shood be? is MLO for be98 regural still in development?

DorR_0-1713433194619.png

 

Please send to me as well.  Having issues lately with it and want to give the new beta firmware a shot.

plz send it also to me too!

shine_0-1711283214073.png