cancel
Showing results for 
Search instead for 
Did you mean: 

Asus ROG THOR 1600T Gaming 1600 W PSU - No boot/post and no QLED light

PancakeMuffin
Level 8

I am desperate and hoping someone has ideas of what to do!

I just built my computer with all new parts, and I have not been able to post/boot for almost three days. When I turn on the power switch on the back of the PSU, the left side of the motherboard light comes on. And then, when I press the power button on the front of the case, the PSU makes a clicking sound, but the computer does not boot or post. No fan spins, no lights on the QLED, etc. The only light that comes on is the left side of the motherboard (see photo below). 

motherboard light.jpg

Could this be a faulty PSU or motherboard?

Here are the things I have tried:

  • Reseated all the cables
  • Tried a single stick of RAM
  • Tried all DIMM slots one at a time with each stick of RAM
  • Tried only PSU and motherboard
  • Reset CMOS battery
  • Checked all other connections
  • Took whole thing apart and built them from the scratch again

Discovery:

  • To my surprise, ROG THOR 1600T Gaming PSU package did not include CPU 8-pin cable(s) with the correct CPU pins shape for my motherboard, so I ordered two new one from Amazon.

My specs are:

  • Asus ROG THOR 1600T Gaming 1600 W 80+ Titanium Certified Fully Modular ATX Power Supply
  • Intel Core i9-14900K 3.2 GHz 24-Core Processor
  • Asus ROG STRIX Z790-E GAMING WIFI II ATX LGA1700 Motherboard
  • Asus TUF GAMING GeForce RTX 4080 16 GB Video Card
  • Lian Li O11 Dynamic EVO XL ATX Full Tower Case
  • Corsair iCUE H150i ELITE CAPELLIX XT 65.57 CFM Liquid CPU Cooler
  • Corsair Vengeance 64 GB (2 x 32 GB) DDR5-5200 CL40 Memory (2 of this, so total 4 x 32 GB)
  • Western Digital WD_BLACK 6 TB 3.5" 7200 RPM Internal Hard Drive (3 of this)
  • Samsung 980 Pro 2 TB M.2-2280 PCIe 4.0 X4 NVME Solid State Drive
  • Corsair iCUE SP120 RGB ELITE 47.7 CFM 120 mm Fans 3-Pack (2 of this)

I appreciate any help I can get on this. Thank you!

357 Views
1 ACCEPTED SOLUTION

Accepted Solutions

Update: I ordered a Corsair AX1600i PSU, and it arrived today. I put the PC together, and it posted and booted with no problem. I will be returning the ROG THOR 1600T Gaming 1600 W PSU this week. 

View solution in original post

2 REPLIES 2

PancakeMuffin
Level 8

Cross-posting in Reddit.

Update: I ordered a Corsair AX1600i PSU, and it arrived today. I put the PC together, and it posted and booted with no problem. I will be returning the ROG THOR 1600T Gaming 1600 W PSU this week.