Showing results for 
Search instead for 
Did you mean: 

rog phone 7 external DAC does not work properly

Level 7

After I changed to rog phone 7, my DAC is not working properly, the DAC light is on, the volume control key is also normal, but there is no sound, the strange thing is that occasionally it will be normal after reinsertion, about ten times it will be normal once, the DAC tested so far are KP1, KA3, W2-131, MOONRIVER 2, in my old ROG Phone 3 are all normal, does anyone have the same situation as me?


Community Agent


Hi, would you please try to update firmware of your DAC first? Thanks

Level 7

Same for my rog 7, my Tanchjim Space Lite has no sound also, then i've tried it on my samsung tab s8 and it is working fine

Level 7

Did this ever get figured out? I have a KA3 also, works with my other phone, and on my laptop, but no sound on my phone 7. I've updated the firmware of the dac, that didn't change anything. When I plug it in, it shows it's output is USB audio through Fiio KA3, but there is no sound

Level 7

I reported this issue (moonriver2) on ZenTalk couple weeks ago and mod there told me it will be fixed on next update

Level 7

Same here, I'm using Shanling ua5 + 64audio nio, still no sound 😭😭😭

for now I will just using my quarks dsp type c that works normal on my 7 ultimate 😅

edit : forgot to mention it was works normal on my rog phone 3

Level 7

I have the same problem, it works when I open the "Armoury crate" app but if I stop the audio for few seconds then there's no sound again

So after you open the armory crate once the dac then can be works normally? 

Yes, but if I pause the song and Play it after 3 seconds, the sound is gone. Then I have to open the Armoury crate app again to be able to listen to music.

My DAC is Fiio K5 ESS

Another homework for asus rog teams then lmao