Showing results for 
Search instead for 
Did you mean: 

ROG Strix Scope NX deluxe and ROG Gladius II

Level 8


Yesterday I installed the new framework for those two pheripherials and the letter 'C' does not work properly. I reset the keyboard and then deleted it from the device manager in Windows 11. Now it's showing this:
(sorry for the lanugage, it's Hungarian.)


It's totally mixed up and if I delete the keyboard from the mouse seciton and after the restart it is still there. Is there any solution for this?
Sorry for my English.



Hello takriulZ,

This is normal and nothing to worry about, mine shows my keyboards under mice and my mice under keyboards.

If it's showing two as yours is, it's showing one for wired and one for the wireless receiver.

Is the letter 'C' working?

Here is my device manager.



Hey Nate!

Oh okay this is good to know! 🙂

Now it is working. But rarely doesn't recognize if I push or adding into my typing twice. It came up 3 days ago. I'll be checking this week and get back to you if it's doing the same. 

Can I leave this post open?

Persze! Amint lesz valamim, akkor szólok!

Hey @Nate152 

Could you please help  us  out  here? Bertu has  a  similiar  problem like mine. I have the  problem where the 'C'   and SPACE button not  works properly. When I typing and  pushinng those  buttons  for  example the  space  move 2-3 spaces instead  of one. Or  sometimes just  not  working. C is the same.

Bertu has a problem  with A and D buttons.

Both are clear uninstalled  and  innstalled back the armory. But nothing happned.  All the other buttons just works fine. Maybe  a  firmware issue?

Thanks for helping  us  out.

Try resetting your keyboard by pressing and holding the Fn + Esc keys for 10 - 15 seconds.

Then check Armoury Crate for updates.

Yepp! Did everything. Many times. As I saw @Bertu has a problem too with it. As I saw someone removed our conversation because it was Hungarian! Anyway he replaced his and the same happened with the new keyboard with the same letters. I think it is firmware problem or maybe it is in the regedit. Something is wrong with Armory Crate. 😕 When I was reinstalled it (used uninstall tool first) The program didn't recognize my fans, so I had to uninstall it and then reinstall it again. So maybe the problem it is in the program or with the firmware.

Hey Nate!

I didi it multiple times but without any success. My space button barely working, sometimes recognize the key hitting twice or not  at all. Same with letter C and N. I don't know what to do here...

I  don't  know what is  happening but I tried everything. Nothing worked  for me.


Level 8

Hi @Nate152!

I reset my keyboard installed everything from the armory but nothing happened. It started when I played Diablo 4.

I cannot type properly because the SPACE and C buttons are missing the keystrokes or if they not missing then the keyboard detects the keystrokes twice.