cancel
Showing results for 
Search instead for 
Did you mean: 

Rog spatha x battery is not charging

sdarkdy
Level 7

I recently purchased the ROG spatha x mouse and now battery is stuck at 28% and won’t charge beyond i try charging it by docking it and by connecting the usb directly to the mouse but it no use is there a way to fix this or should i return to amazon as i still could

377 Views
7 REPLIES 7

Aureliannn_ROG
Customer Service Agent

Hi @sdarkdy ,

we apologize for the delayed response due to the holiday season. 

Could you please provide more details about when this issue occurred? 

Does it happen in both wired and wireless modes? Is your mouse currently functional? 

When charging, does the battery level always remain at 28%? 

Have you ensured that both your mouse and receiver firmware are up to date? 

Additionally, could you provide screenshots of the Armoury Crate update center and logs for our reference? 

Please confirm that the logs have accurately recorded the issue at the time it occurred.

Here are the steps: Start logging > Charge the mouse for a period of time > Use the mouse with a wired connection > Use the mouse with a wireless connection. For log operation steps, please refer to Q5: What is App Diagnostics? (New Feature)
https://www.asus.com/support/FAQ/1043747/#a14

After recording the log, please upload it to the cloud, approve access, and PM me the link.
Additionally, kindly provide the product serial number too, thank you.

the mouse has been connected on usb since i wrote the the issue last time it's still on 28%  checked for update there is no new update and  attached requested photos and gdrive link for the logs 

https://drive.google.com/file/d/1evAGhW0WrDarafAnwyCUAxjb8PMuD4cT/view?usp=drive_link

Screenshot 2024-02-16 133312.pngScreenshot 2024-02-16 133831.pngScreenshot 2024-02-16 134048.png

Aureliannn_ROG
Customer Service Agent

Hi @sdarkdy ,

thank you for providing the information. 

Regarding your question, if you use the dongle to connect the mouse, does the battery level still show 28% charging? 

Have you tried using the uninstall tool to uninstall and reinstall the software? Please assist in confirming this. 

Additionally, we were unable to open the link you provided. Please do not restrict access, thank you.

I tried uninstalling armoury create and downloaded from the mouse support page and i removed the restriction on the link please try it again

Aureliannn_ROG
Customer Service Agent

Hi @sdarkdy ,

thank you, we'll forward your case to the backend team.

Additionally, could you provide the product serial number via private messege to me?

Thank you.

the  mouse serial NO / NCMPCP001736 and i PMed it to you 

Aureliannn_ROG
Customer Service Agent

Hi @sdarkdy ,

thanks for the information.

We've passed your details on to our relevant backend team for analysis. 
Please be patient and wait for any updates or messages from us. 
Thank you.