cancel
Showing results for 
Search instead for 
Did you mean: 

ROG Delta S Wireless not turning on.

Zinbalu
Level 8

Hello,

For some time my headphones (ROG Delta S Wireless) don't turn on, no matter the mode (2.4 or BT). In attempt to fix this I connected them to my pc with the provided cable and then I noticed there is a firmware update available in Armoury Crate. I started the update, the headphones turned on, the LED started flashing and Armoury Crate indicated an error during update. Then I started the pairing tool that I had from the ASUS website and the headphones paired successfully and worked all fine.

If I turn them off I have to do this process all over again every time or the headphones won't turn on. Is there any solution to this behavior?

I have Windows 11 updated and all Armoury Crate updates.

177 Views
8 REPLIES 8

MrAgapiGC
Level 13

put the unit to charge. if after 8h still NOT turn on contact asus support

Learn, Play Enjoy!

I tried charging it for over 24h. When I reconnect it with the above method it shows 100%. If I keep using it, the battery discharges as normal. No matter the battery level, if I switch it off, it doesn't turn on unless I do the same procedure.

then asus support!

Learn, Play Enjoy!

Aureliannn_ROG
Customer Service Agent

Hi @Zinbalu ,

based on your question, may I inquire if the issue arose after a firmware update? 

Is it necessary to use the tool to re-pair the headphones every time you turn them on after they have been turned off? 

When you mention the problem of being unable to turn them on successfully, does this mean that none of the indicator lights illuminate? 

Could you provide a video showing the headphones failing to turn on after being turned off, and then successfully connecting after using the tool to re-pair? Additionally, please provide a screenshot of the Armoury Crate update center and the logs as requested. 

Please ensure that the logs accurately capture the issue at the time it occurred. For log operation steps, please refer to 

Q5: What is App Diagnostics? (New Feature)

https://www.asus.com/support/FAQ/1043747/#a14

After recording the log, please upload it to the cloud, approve access, and PM me the link. 

Additionally, kindly provide the product serial number. 

Thank you.

rule of knowledge. and write it down. If the headphone or any product, does not power on and does not appear in windows that the items are present, there is not log to record.since windows does not see it. that is the first has to be check. No item present no point to ask for a log since you need to be there first to actual record something. you can not magical work on something if that is not present.

the ac i can deal with it . on that later. 

That is why told userr after the small question to contact support direct. since does not manner what does . if the item does not turn on or appear in window is a end of road. Now if the item appear on windows mean that is windows is reading it. hen that log can be turn made. but if the items does not appear in windows there is nothing we can do.

Learn, Play Enjoy!

Hey @Aureliannn_ROG 

Thanks for your assistance. I was away for a few days. When I came back I noticed that there is new firmware version for update (0.0.0.20). My headphones were on 0.0.0.16 and I was trying to update to 0.0.0.18 previously.

I tried to update to 0.0.0.20 but the update failed, so did a dry run before recording the video and it failed again. So I started recording right after that and then the update went through and it seems to have fixed the issue. The headphones now properly turn on and connect to the PC in 2.4GHz mode.

I haven't tried leaving them off for a longer period, but I hope everything will be okay. I'll let you know if it happens again.

Aureliannn_ROG
Customer Service Agent

Hi @Zinbalu ,

Thank you very much for your feedback!
We are pleased that you resolve the issue. 
If you have any other questions or need further assistance, please feel free to ask.
We are here to assist you.

Hello. I'm having the same problem as the OP, except I cannot get the pairing tool to work. When I move the switch to either 2.4g or BT, it does not turn on. No light comes on, and no power up sound is heard in the headset.

When I connect the headset (not the dongle) to my computer, the charging light turns on as if it's charging, but still will not power on.

Additionally, when I have the headset connected to my computer and move the switch to 2.4g, I hear the windows device connect sound through my desktop speakers. 

When I try to use the pairing tool, it recognizes that the dongle is connected, but the "Pair" button never lights up to allow me to attempt to connect it. 

This started last night, and so I checked Armory Crate for updates, and did find a new firmware. I was able to successfully install that firmware and use the headset for several hours afterward, but once I turned it off for the night, it would not turn back on again. 

The Kraken
Xigmatek Aquila
Asus Rampage IV Gene
Intel i7-4820k
16GB G.Skill Ripjaws X DDR 3 1866MHz
Asus Geforce GTX 780Ti DirectCU II
NZXT Kraken x60
Corsair AX860
Creative Soundblaster ZX