cancel
Showing results for 
Search instead for 
Did you mean: 

ROG Azoth Not Powering On

SweatMode
Level 7

So I got my ROG Azoth keyboard today, and I turned it on and it powered on. I connected it to my PC and it was working, but right as I was downloading Armoury Crate, it turned off. So I charged it for about an hour, and it still isn't powering on. Nothing is working with the keyboard, not the OLED display, the typing, nothing. I hope this isn't faulty so can someone just help me out with this issue?

428 Views
5 REPLIES 5

Nate152
Moderator

Hello SweatMode

Some suggestions....

1) Maybe try a different usb port on your pc.

2) Try both wired mode and 2.4GHz wireless mode.

Wired mode - Connect the cable to your ROG Azoth and a pc usb port, set the wireless switch on your ROG Azoth to wired mode (switch set to the center position).

Wireless mode - Connect the wireless dongle to a pc usb port. With your ROG Azoth in front of you, slide the wireless switch to the left.

3) Try resetting your ROG Azoth by pressing and holding the Fn+ Esc keys for 10-15 seconds.

4) Try uninstalling and reinstalling Armoury Crate.

 

 

SweatMode
Level 7

Hi,

Thanks for the reply, However, I have already tried everything. Nothing works and the keyboard isn't powering on. Pressing FN and ESC for 10-15 secs won't work because the keyboard isn't on and I can't set it to RF 2.4GHz to customize it on armoury crate because the oled won't turn on. I've tried all the USB ports and nothing works.

Nate152
Moderator

Ok, since it's not powering on for you, I'll have you contact ASUS Technical Support for further assistance.

I don't see a phone number for peripherals for your location, so I'll post the technical support phone number for monitors. If they can't help you, I'm sure they'll redirect you to the proper department.

ASUS (India) Technical Support phone number for Monitors: 1800-2090365 (Mon - Sat 09:00-1800)

Let me know how you make out.

 

 

 

 

 

Monday1998
Level 7

I got my question as well , when i plug off the wire then it direct cut off my power , it wont let me use Wireless mode or bluetooth mode either ! How to solve this problem?

Aureliannn_ROG
Customer Service Agent

Hi @SweatMode @Monday1998 ,

could you please confirm if the issue occurred after installing Armoury Crate, and regardless of using Bluetooth, wired USB, or 2.4G connection mode, the keyboard is unresponsive? 

Can Armoury Crate recognize your keyboard, and have you verified that Armoury Crate is up-to-date along with the keyboard firmware? 

Please provide a screenshot of the Armoury Crate update center. 

Additionally, we would appreciate it if you could record and share relevant logs for further investigation. 

For log operation steps, please refer to Q5: What is App Diagnostics? (New Feature) 

https://www.asus.com/support/FAQ/1043747/#a14

After recording the log, upload it to the cloud, approve access, and send me the link. 

Thank you.