cancel
Showing results for 
Search instead for 
Did you mean: 

Gladius II Origin Bricked Firmware

Oxeia
Level 7
My ROG Gladius II Origin died while doing an update via Armoury Crate. I've tried unplugging it, holding down the left, scroll, and right buttons and reconnecting it like it says in the manual but all that shows up is a drive called NXP LPC1XXX IFLASH USB Device that's labeled "CRP DISABLD" with a 128 KB file called firmware.bin. It was fine before the update.

I've tried connecting it to two other computers and doing as the manual suggests to restart the firmware install. One has Armoury Crate installed and the other does not. All that shows up is that flash drive. No lights or anything.

Any ideas?
176 Views
2 REPLIES 2

Aureliannn_ROG
Customer Service Agent

Hi @Oxeia ,

In relation to your concern, could you confirm if your current Armoury Crate recognizes the mouse? 

Additionally, would it be possible for you to provide screenshots displaying NXP LPC1XXX IFLASH and CRP DISABLD? 

Is this information visible within Armoury Crate? Have you tried uninstalling and reinstalling Armoury Crate? 

Kindly assist by providing a screenshot of the Armoury Crate Update Center. 

Could you also help record and provide the relevant logs for us to investigate further?
For log operation steps, please refer to Q5: What is App Diagnostics? (New Feature)
https://www.asus.com/support/FAQ/1043747/#a14
After recording the log, please upload it to the cloud, approve access, and PM me the link.

Thank you.

Hi @Oxeia ,

in oder to better assist you, we have sent you messeges via PM box.

Please kindly check the private messege at the top right corner.

Thank you.