Showing results for 
Search instead for 
Did you mean: 

Chakram X disconnects itself, doesn't change connection type and doesn't update firmware

Level 7

My ROG Chakram X started disconnecting by itself (wired and wireless). The strange thing is that the PC recognizes it connected with USB regardless of whether the connection type is changed to Bluetooth or 2.4Ghz (the motherboard doesn't have a Bluetooth connection and the tongle is disconnected).

I tried flashing the firmware with Armory Crate but when it starts to install it throws error Code 4181.

I already tried formatting the PC, connecting it to another PC (notebook) and I couldn't get it to work properly.

When I plug it in, Windows recognizes it as a bootloader device

Any solution to this problem?
Is it possible to update the firmware without using Armoury Crate?

(Sorry for my bad English)


Customer Service Agent

Hello, @LeonelM

Could you please clarify whether you are using a wired connection when operating the firmware update on the ROG Chakram X?
Have you tried using the Armoury Crate uninstall tool to uninstall it and reinstall via the official website support page, finish the update again, and reboot? 
If not, please try using the uninstall tool and reinstalling it.
Please provide the following information to help us better understand your issue:
- Is the mouse currently connected to a PC or laptop? What is the brand, model, and OS version?
- Has Armoury Crate been updated to the latest version? Please provide a screenshot of the Armoury Crate update center.
- Please provide a video showing the connection issue you described, including information about the mouse connection method and any abnormal error messages that appear.

Thank you.

Hello, @Jiaszzz_ROG 
I tried to do the update by wired and wireless (2.4 Ghz) connection.
I tried uninstalling and reinstalling Armory Crate (Full and Lite Version) and also formatting the PC but got the same result.
The mouse is connected to a PC with an Asus TUF X570 Plus motherboard. Anyway, I tried to update it from a Dell Latitude 5490 notebook and that didn't work either.

Armoury Crate is updated to the latest version:ArmourCrate.PNG


Now I can't even try to update the firmware anymore because Armory asks me to connect the wired mouse and 2.4 Ghz receiver but no matter how much I connect it that way, it doesn't proceed with the update:ArmouryCrate2.PNG

Video showing the mouse connected:

Customer Service Agent

Hello, @LeonelM 

Thank you for sharing the details.
Could you also help record and provide the relevant logs for us to investigate further?
For log operation steps, please refer to Q5: What is App Diagnostics? (New Feature)
After recording the log, please upload it to the cloud, approve access, and PM me the link.

Thank you.