cancel
Showing results for 
Search instead for 
Did you mean: 

Azoth - USB cable connection stopped working

Kav91
Level 7

Have had my Azoth for week or so now and suddenly when switching outputs the usb cable option doesn't work.

When I've switched to the middle cable option the RGB will be on, but it will not accept any inputs, then suddenly after a few seconds the RGBs will turn off and the OLED screen just shows a battery charging icon.

I've tried to FN+ESC reset which did not fix it.

Switching to the USB wireless dongle works okay I can see the keyboard in armory crate too, and bluetooth seems to be okay (however bluetooth was broken till I did the FN+ESC reset)

Is this a hardware or software failure?

  • Azoth - ASUS framework service: 4.1.0.13
  • Keyboard version: 4.00.07
  • Dongle version: 3.00.19
  • Armory Crate: 5.7.9.0
344 Views
1 ACCEPTED SOLUTION

Accepted Solutions

@Aureliannn_ROG yes that is exactly as I described no response, and I also provided you all my versions which were the latest. None of your solutions work.

However I did find the solution myself, this keyboard has a problem where it can register itself under Device Manager under Other Devices with name "ROG Azoth" as a disabled device. If you try and re-enable it, you'll see the keyboard create the same behaviour and turn on for a few moments before switching off again.

The solution is to uninstall it from Other Devices, the driver software does not need to be deleted so you can leave the checkbox unticked, then unplug the device and plug it back in and windows will sort itself out and everything comes good.

No need to touch Armory Crate, uninstall it, or uninstall any specific drivers.

View solution in original post

2 REPLIES 2

Aureliannn_ROG
Customer Service Agent

Hi @Kav91 ,

based on your issue, may I ask have you try to use the Armoury crate "uninstall tool" to reinstall the software?
Whether the issue only occur when using USB cable connection?

Do you experience a complete lack of response from the keyboard when using a wired connection? 

Have you tried cross-testing with other devices? 

Make sure that you update the ROG Azoth firmware update as following link:

ROG Azoth | Gaming keyboards|ROG - Republic of Gamers|ROG Global (asus.com)

Please provide a screenshot of the Armoury Crate update center page and logs.

For log operation steps, please refer to Q5: What is App Diagnostics? (New Feature)
https://www.asus.com/support/FAQ/1043747/#a14
After recording the log, please upload it to the cloud, approve access, and PM me the link.
Additionally, kindly provide the product serial number too, thank you.

@Aureliannn_ROG yes that is exactly as I described no response, and I also provided you all my versions which were the latest. None of your solutions work.

However I did find the solution myself, this keyboard has a problem where it can register itself under Device Manager under Other Devices with name "ROG Azoth" as a disabled device. If you try and re-enable it, you'll see the keyboard create the same behaviour and turn on for a few moments before switching off again.

The solution is to uninstall it from Other Devices, the driver software does not need to be deleted so you can leave the checkbox unticked, then unplug the device and plug it back in and windows will sort itself out and everything comes good.

No need to touch Armory Crate, uninstall it, or uninstall any specific drivers.