cancel
Showing results for 
Search instead for 
Did you mean: 

ASUS AZOTH firmware update

Michaelulu
Level 7

Just got my Asus Azoth keyboard from Amazon today. When I opened Armoury Crate to detect my keyboard, the system showed a required update. So I updated my armory crate to the latest version and then tried to update my Azoth firmware to the latest version which includes HAL version 1.2.49.0, HTML version 4.01.20, and Device SDK version 3.00.42. However, when I clicked update, the system immediately downloaded the required file and then started to install it. There's a window pop-up, but a second later it disappears (I am not even able to see what the window is about) and then the Armoury Crate shows the update option again. It seems like I cannot finish the update of my Azoth firmware update, it just keeps requiring firmware updates. Did someone also meet the same problem? I tried switching to Bluetooth mode, wired mode, 2.4GHz mode, and click update, but none of them worked. I also tried reinstalling Armoury Crate, but still does not help.

475 Views
2 REPLIES 2

Aureliannn_ROG
Customer Service Agent

Hi @Michaelulu ,

based on your issue ,may I ask could you provide the screenshot of the Armoury Crate update center and the system shows the update pop up messege after you update?

Have you try usong Uninstall tool to uninstall then reinstall Armoury Crate?

In order to better assist you, could you also help record and provide the relevant logs for us to investigate further?
For log operation steps, please refer to Q5: What is App Diagnostics? (New Feature)
https://www.asus.com/support/FAQ/1043747/#a14
After recording the log, please upload it to the cloud, approve access, and PM me the link.
While recording the log, please kindly perform the update.

Thank you.

MasterC
Community Admin
Community Admin

Be sure to have both the keyboard (switched to USB mode/OFF) and RF 2.4GHz wireless receiver connected while updating the firmware. Typically, firmware updates are applied to the two devices.

_____________________________________________________________
FPS, Racing, and VR Gamer / Tech Enthusiast / ROG Admin