cancel
Showing results for 
Search instead for 
Did you mean: 

Armoury Crate can´t open individual device settings.

izmaglez
Level 7

Hello all and thank you in advance for any input you can provide, as the title says, every time I go to open any of my devices within AC for individual configuration (like changing the OLED animatgion on my AZOTH) the app just crashes, I've tried it all, I just uninstalled and install back again and nothing.

I'm uploading the Log Data from the crash here: https://drive.google.com/file/d/1gCGaTdt7HH_xi65JzjUsSah5Yi6ZfHN9/view?usp=drive_link

Thank you.

187 Views
4 REPLIES 4

Aureliannn_ROG
Customer Service Agent

Hi @izmaglez ,

Based on your issue, we need to conduct further investigation and understanding to better comprehend and resolve the problem:

  1. Did this issue occur immediately after purchasing the keyboard, or did it start happening recently after some update?
  2. Does entering Armoury Crate to adjust keyboard settings always result in Armoury Crate crashing?
  3. Have you used the official Armoury Crate uninstall tool to uninstall the software and then reinstalled it?
  4. Is your keyboard firmware currently updated to the latest version?
  5. Have you tried different connection methods? If so, does the problem occur with all connection methods?
  6. Have you tried connecting the keyboard to other devices for testing to determine if the problem is related to a specific device or the keyboard itself

Please provide a screenshot of the Armoury Crate update center page and privately message me the product serial number. 

This will help us better understand your problem and provide corresponding solutions. 

Thank you for your cooperation and understanding.

Hello @Aureliannn_ROG, thank you very much for your help. Please review my answers to your questions:

  1. This issue doesn't only happen with the keyboard, but with every device (motherboard, keyboard, AIO and GPU) when I try to access the individual settings. This being said, the problem is new and did'nt happen before.
  2. Yes, everytime I try to adjust inidivual settings it crashes.
  3. I have, I didn't as part of troubleshooting before posting here.
  4. All the device's firmware should be updated.
  5. I have, it happens every time.
  6. I have not, but as I said before the issue is not only with the keyboard, which makes me think the problem is witrh Armoury Crate and not the devices.

I'm including the screenshot of the update center:Update centerUpdate center

Will send you the serial number of the keyboard as well.
Lastly, I don't know if it's related or not, but another issue I noticed by the same time this one started to happen is that when I go to the User Center, I only get a "redirecting" message but it never gives me the option to login.

Thank you again.

Aureliannn_ROG
Customer Service Agent

Hi @izmaglez ,

thank you for the information you've provided. 
We've passed your details on to our relevant backend team for analysis. 
Please be patient and wait for any updates or messages from us. 
Thank you.

Thank you, looking forward to a solution.