cancel
Showing results for 
Search instead for 
Did you mean: 

Zephyrus G16 Micro stuttering when using discrete GPU.

Rogikel
Level 9

Update: (TL;DR fixed the stuttering by disabling G-Sync, surprising.) G-Sync caused older games to act weird too.) Issue is basically completely fixed, I first cleaned my laptop from dust as it was overheating and I thought it could be throttling, it helped reduce the stuttering. Next thing I did is to try out different V-Sync options in the Nvidia control panel, turns out that setting the V-Sync to "On" managed to reduce the stuttering, but whenever the fps dropped below the refresh rate it would stutter, thus causing stutters at 60 FPS games when I'm using 240Hz. Managed to fix it by putting my refresh rate to 60Hz whenever playing a game that's locked on 60 fps. Last thing I did is to disable G-Sync, it was probably the root of the stuttering all along. Turning it off made me have tearing when turning off V-sync, but honestly tearing is better than stuttering for me, and I don't turn off V-sync in games anyway. Also, for some reason replugging my charger fixes stuttering sometimes, so weird.

I've only noticed this issue whenever I use the discrete GPU of this laptop (RTX 4060), I notice micro stutters both in-game and when browsing (By micro stutters, I mean extremely small stutters that happen at some sort of intervals which make the game (or video, when browsing) look like it's at a way lower FPS for a very tiny period of time, the FPS counter doesn't manage to track the stutters in game, and it is frustrating as the gameplay experience isn't smooth at all, forcing me to notice these stutters)

Here is what I tried:

- Reinstalled every single driver that was recommended for my laptop's model (no changes, it may actually have gotten worse), then I tried installing the newest drivers offered by Nvidia (no changes, rolled back to the Asus-recommended drivers)

- Uninstalled Armoury Crate completely (Used GHelper instead, nothing changed at all)

- Tweaked a lot of Nvidia's control panel settings (disabled/enabled GSYNC (no particular changes), Changed max frame rate(no changes), changed the V-Sync options(no changes), set the openGL rendering gpu to my discrete gpu(micro stuttering ssignificantly reduced, but is still there), set the power management mode to Prefer Performance(no changes))

-In windows settings > graphics, I turned off Variable Refresh Rate (VRR), no changes.

- Tweaked some options in Armoury Crate (tried to use Turbo mode (no changes except the fact that my fans got louder), switched between GPU Modes (Ultimate (no changes), standard/optimised (stuttering only gone when iGPU is being used, but no changes when using discrete GPU.)). Tried setting custom fan curves (No changes, actually I noticed that the fans don't actually end up reaching the set RPM speed, which is strange)

- Updated BIOS (no changes)

- Followed a reddit post that promised to fix stuttering for laptops like mine and ended up completely uninstalling one Armoury Crate service (AutoConnectHelper, no changes..)

- Reset my PC completely 2 times. Actually, after the first reset, this is probably when I started seeing this issue.

I'm sure that I probably tried way more things but this has been an issue for so long that I kind of forgot some of them. This issue has been noticed by me around 1 month after getting my laptop, and it has been an issue for 3 months now. I'm not sure what my model is but it says GU603ZV, I have an RTX 4060, an i7-12700H, 16gb RAM, 1TB SSD and a 240Hz display (issue still persisted at lower frame rates, such as 120Hz), Windows 11.

Additional info:

I monitored my CPU's temperature during gaming, it can very well reach up to 90 degrees Celsius, yet the fans don't really sound as loud as they should be to cool the CPU down. I monitored my frame rate using Armoury Crate's monitoring features, It kind of goes up and down and theres no true stable FPS, it kind of goes from 240-237 constantly. Also, prior to this stuttering issue, I noticed some strange behavior in my laptop's charger; there has been a time when I randomly got a pop-up from windows telling me that "My charger is plugged in incorrectly) Or something like that. It happened twice, but now I don't really see this issue happen anymore.

Any help is appreciated, I'll try anything at this point. It may not be that important of an issue, but it's better to try and fix it rather than dealing with it..

 

1,036 Views
1 ACCEPTED SOLUTION

Accepted Solutions

Rogikel
Level 9

Okay, so I kept messing with nvidia control panel and turning on V-Sync managed to reduce the stuttering to a point where it's acceptable for me, they're still there but I guess it's better than what it was before. Thanks to Anbby for trying to assist me through this, won't disturb you any further.

View solution in original post

8 REPLIES 8

Anbby_ROG
Customer Service Agent

Hi @Rogikel ,

Please ensure that your system has been updated to the latest BIOS version 313 and is using the ASUS-certified NVIDIA graphics card driver version V31.0.15.3168. This is a crucial step to ensure the proper functioning of your system.
Regarding the charger issue, please make sure you are using the original charger. If you are using a different charger, it may trigger a system alert about the use of a non-original charger that could affect performance.

To better understand and address your issue, kindly enable the Log recording feature in Armoury Crate and download relevant information using HWinfo during the occurrence of micro stutters. Additionally, record a video during the stuttering incidents and provide the following information through private message. This will help us gain a better understanding of your problem. Thank you for your cooperation.

Serial Number:
Windows Build Version: (Settings - System - About)
Armoury Crate SE > Content Tab > System > About > Service Version > Check Button (Copy all content):

【Here is the file path for the log file for your reference】 
In Armoury Crate "Settings" and check "About" page, If clicking App Diagnostics "Record Log", the Privacy Policy Statement will pop out. Once user agreed statement, the Armoury Crate will start to collect problem log  and you can click "Generate log data" to generate the log file with encrypted (ASUS log file).

Hello, thank you very much for replying and providing me with some ideas, I haven't tried everything at the moment but as of now I can tell you that my BIOS version is indeed 313, I am about to reinstall the ASUS-recommended graphics driver and I'll let you know how it goes. As for the log recording and other ideas you provided, I will do it all after reinstalling the drivers. Thank you again.

Rogikel
Level 9

I did a clean install of the recommended driver for my discrete GPU, I'll let you know how it goes.

Anbby_ROG
Customer Service Agent

Hi @Rogikel ,

Thank you for your response. Looking forward to hearing good news from you.

Hello, yesterday night I did a clean windows reset on my laptop (I didn't have much to lose anyway, I thought maybe I turned on some setting on accident that caused the stuttering), and I have noticed two things:

The first thing is that my current display's resolution (1920x1080 240hz, I don't need a very high resolution for gaming) does not match the "active signal resolution" setting that I noticed after checking the "advanced display settings" tab in windows settings > display (it is stuck on my native resolution, 2560 x 1600, the only thing that changes along with the 2 resolutions is the refresh rate), which made me think that could be a potential cause to the stuttering, but I'm totally unsure as I have no idea what an active signal resolution is, and I why would a high active signal resolution cause stuttering *only* on my Nvidia GPU? In any way, I tried to change it by going through some forums which had the same problem as me, but unfortunately I didn't really find any working way of changing it, so I gave up on that.

The second thing that I noticed, is that my discrete GPU's graphics driver version does not actually match the one you recommended to me (you recommended me V31.0.15.3168 but my driver's version is V31.0.15.3645) and I think this may have happened after I reset my laptop, so I'm going to look for the driver version that you recommended me.

I also found a site today which generates moving white lines (probably to detect stutters?) and I used it to track the stuttering, I will provide 2 videos in the next message, the first one will be using the integrated GPU while the 2nd one will be using the discrete GPU (which has way more stutters)

Thank you for replying.

Update: I updated the drivers to the ones that you recommended, there have been no changes, but could this be an issue with the monitor perhaps?

Here are the videos:

Using Nvidia GPU:  https://drive.google.com/file/d/192t-onThSBaUbFEiIrqLJQi2nG7krfAT/view?usp=drive_link 

Using integrated GPU: https://drive.google.com/file/d/1NrOk5FTMtmUCiX2u-cYSMgYUUimpL2m4/view?usp=drive_link 

While you may not notice the actual stutters due to the low FPS when uploading the videos, you can notice that the refresh rate drastically decreased when using the dGPU, and it detected way more stutters than when using the iGPU. Maybe there's an issue with some part in the laptop like the motherboard, the fans or the graphics card itself? Not sure, but I'm totally willing to send my laptop for a part replacement if needed. Maybe this is also an overheating issue, since I noticed my demanding games make my CPU reach 85-90 degrees Celsius, so the fans may need cleaning or a replacement, but I have no idea how to open up the laptop and correctly clean the fans from the dust. It could also be a problem with the charger, but I don't know if my warranty covers the charger too.

Rogikel
Level 9

I made a post on reddit about my issue for more ideas and somebody told me to turn off game mode in windows, I guess it's back to messing with windows settings. I don't mind though, as I didn't try that before. Somebody also told me that it's more of a drivers issue as apparently newer versions of the driver had been reported having the same issues as me.

Rogikel
Level 9

Okay, so I kept messing with nvidia control panel and turning on V-Sync managed to reduce the stuttering to a point where it's acceptable for me, they're still there but I guess it's better than what it was before. Thanks to Anbby for trying to assist me through this, won't disturb you any further.