cancel
Showing results for 
Search instead for 
Did you mean: 

USB-C to HDMI crashed windows ASUS TUF Dash F15

LEVELS641
Level 7

Hi all sorry for bothering but I desperately need help

 

I have a ASUS TUF Dash F15 FX516PR

https://www.asus.com/laptops/for-gaming/tuf-gaming/2021-asus-tuf-dash-f15/helpdesk_download/?model2N...

and whenever I attempt to connect to my external display through my usb-c to hdmi adaptor (QDOS) 

https://www.qdossound.com/products/qdos-powerlink-combi
windows will do the detected new display animation and then immediately proceed to freeze 

(Built in hdmi display out is use for my main monitor)

 

I do feel the need to point out that the usb-c hub can be plugged in and have other devices in use without causing a crash … that is until a hdmi cable is plugged into it , and that I have been using it every day without any hassles for it to magically not work a few days ago

 

the HDMI can be plugged into the usb-c and when the computer is in bios mode and the computer won’t crash which reaffirms my thoughts that it is a windows issue and not a power surge issue 

 

have also tested different hubs and tv’s and still causes crash

 

adapters and tvs all work fine with a different computer also 


I have attempted the following fixes 

 

Windows reinstall (clean)

 

installed all new driver and bios 

https://www.asus.com/laptops/for-gaming/tuf-gaming/2021-asus-tuf-dash-f15/helpdesk_download/?model2N...

 

updated all drivers in device manager (literally all)

 

removed/reinstalled all drivers in device manager (literally all) 

 

used intel driver and support assist (all up to date)

 

my ASUS (all up to date)

 

usb-c to hub runs fine with nothing else plugged/as well as everything plugged in (other than the hdmi)

 

monitor is a standard Samsung tv , but did insure windows was set to 60 fps in settings and display settings 

 

windows will crash on windows boot if usb-c hdmi is pre plugged 

 

 

I honestly don’t know what else to try 


looking forward to any responses 

sincerely 

AC

1,022 Views
7 REPLIES 7

Anbby_ROG
Customer Service Agent

Hi @LEVELS641 ,

May I ask, is that connected to the power at the same time?
Have you tried connecting the monitor directly to the computer (without using a hub) to see if the issue persists?
If the issue persists please feel free to PM the following information we will feedback to relevant department to help confirm this issue. Thank you
Serial number (S/N):
BIOS version: 
Windows OS version:
Video of when the problem occurred:

the hdmi connector stopped working for hardware reasons that's why i was using the hub

joek1976
Level 7

I ran into this issue as well, just started last week after a few updates and Nvidia.  Tried rolling everything back and even installed the Intel updates nothing seems to work.  Soon as you plug-in a hub with HDMI connected it locks the system and max the fan.  Others have tried a few options from MS Support no luck.  Getting someone on the phone at ASUS is difficult to try and work the issue.  I am not about to reload my OS, since other users have attempted that as well.

Anyone have suggestions?

Anbby_ROG
Customer Service Agent

Hi @joek1976 ,

I have sent you a message, please check✉. Thank you🙂

AzureWarlord
Level 7

Hi @Anbby_ROG 

I am facing the same issue, can you help? Thank you

Anbby_ROG
Customer Service Agent

Hi @AzureWarlord ,

Due to the need for your personal information.
I have sent you a message, please check✉. Thank you

AzureWarlord
Level 7

Hi,

From what I know from scouring different fourms this issue was happening with many asus laptops and asus is not keen on fixing anything, the only advice their technicians can give is use laptop hdmi port directly a total waste of money going to service center and I spent a fortune on my dock for a clean setup now it is naught.

This is happening all over the board, but why is there not a fix yet, maybe Asus just don't care.