cancel
Showing results for 
Search instead for 
Did you mean: 

ROG Zephyrus S17 No Audio in Linux OS

theYogster
Level 7

I am trying to use my ASUS GX701LWS to run Linux operating systems from USB memory.

I have several versions of Linux operating system separately installed on a SanDisk Ultra Flair USB 3.0 Flash drive.

They all boot and operate as expected with one exception. There is no sound.

The audio level indicator in the sound settings control panel shows audio is playing, but it is not heard from the internal speakers.

Audio can be heard from the headphones jack.

I verified that audio is heard in Windows 11.

 

I did the following to troubleshoot the problem:

 

Checked that the audio is not muted.

I reinstalled the Alsa audio drivers and Pulse audio server software to the current version.

I selected the Intel audio from the motherboard as a source and tested the speaker output

I selected the Nvidia card audio as a source and tested the speaker output

I tried booting the Linux operating system from both USB 3.2 Gen 1 ports

I tried booting the Linux operating system from a Mokin USB-C hub connected to USB 3.2 Gen 2 Type-C®/Thunderbolt 3/DisplayPort.

My last test was to boot the Linux operating system on the USB flash memory from my desktop computer which has an ASUS ROG MAXIMUS VII RANGER Rev 1.xx (S/N 140626880301329) motherboard. The audio played and was heard in the speakers in that system.

 

Since the only time there is no audio is when booting Linux from my notebook, I can only assume there is something wrong with my ASUS GX701LWS notebook.

 

What is the next thing I can do?

260 Views
4 REPLIES 4

xfantasx
Level 7

I have the same issue with my Asus G614JU.321, and using Ubuntu 22.04.3, the sound simply doesn't work, any advise?

It's not just Ubuntu.  I have half a dozen other distros on USB flash drives and none of them have audio from the Zephyrus speakers.  Headphones work fine.  To be fair ASUS claims not to support Linux, but I have other products from them which run Linux very well.  Hopefully somebody has a fix or it's not looking good for ASUS next time I need a new computer.

Anbby_ROG
Customer Service Agent

Hi @theYogster  @xfantasx ,

Unfortunately, but as the GX701LWS 、G614JU laptop does not come with Linux OS pre-installed.
We are unable to make system corrections specifically for Linux . 
If you encounter any Linux related  issues, we recommend referring to the website information about Linux to address the problem. 
Thank you for your understanding.

Anbby_ROG - thank you for your response and explanation.  This is a very common non-solution I've experienced in a few other places where the hardware people claim no responsibility for the software installed and the software people point to hardware being the problem.  It's a classic Catch-22 where nobody takes responsibility.  In this instance I suspect the issue is in the (UEFI) firmware.  The lack of audio is specific to the GX701LWS laptop in that the Linux OS on the USB drive works flawlessly on other motherboards, one of which is an ASUS product I might add. 

I guess all I can do is learn from past mistakes.