cancel
Showing results for 
Search instead for 
Did you mean: 

ROG XG Mobile issue

ferrariwa
Level 7

Hello

I have an Asus ROG Gaming laptop, model=GZ301ZE-LC218W.

Until this week i have never used the ROG XG Mobile (GTX3080).  So tried it for the first time and seemed to connect/work ok.  However there were some OS updates which resulted in the device restarting (without disconnecting the XG Mobile using the recommended method).  Since the restart, it wont reactivate- that is i dont receive the prompt to activate it.  i have tried a clean install - after which the tutorial does come up but not the activation prompt.  Also tried all latest drivers from the ASUS drivers website.

Have checked other similar forum posts and non work so not sure what to do or check at this point.

the warranty on the laptop device expired 5 months ago so not sure if i could still get help on this from Asus (UK based).  if not then i have a very expensive piece of failed hardware (recognising my fault for never opening and using the XG Mobile).

either way it does look like a hardware failure when i have used it once.  Could also be a common issue.

thanks,

403 Views
2 REPLIES 2

Anbby_ROG
Customer Service Agent

Hi @ferrariwa ,

 

I'd like to confirm with you if there are any changes in the indicator lights on the port after the XG Mobile is connected. Have you tried using the uninstall tool to remove Armoury Crate and then reinstalling it for testing?

If reinstalling Armoury Crate doesn't resolve this issue, could you please private message me your Laptop and XG Mobile serial numbers for further verification? Thank you.
 

Due to the ongoing regional holidays, my responses may be slightly delayed.
Thank you in advance for your patience.‌‌‌‌

hello

i did uninstall and reinstall Armoury Crate but this did not work.

There are no lights on the port when connected (no lights on the XG mobile itself either and im sure there were back when powering on for the first time).

thanks,