cancel
Showing results for 
Search instead for 
Did you mean: 

ROG Strix G16 Keyboard and USB issues

EthanEsh
Level 8

Im dealing with some confusing issues on a new laptop. I have an issue where the laptop keyboard and any connected USB devices randomly stop functioning. A restart fixes the problem, but only temporarily. I have sent it in for RMA twice now, but the team has not been able to locate the issue either time. Does anyone here have any idea what could be causing it?

More info: Ive tried a factory reset after softer fixes like updating every driver I could think of. The RMA technicians also tried replacing the motherboard. Connected to the laptop I have a keyboard, mouse and USB headset. These dont cause issues on any other computers, so I dont think they could be causing the issue. I havent noticed the issue happening when nothing is connected, though. I have also noticed that there is an unusual amount of audio crackling/stuttering before the issue happens. Finally, Ive noticed that the issue seems to occur when Im playing some kind of media on the laptop (videos, games, etc.)

I can provide any other information that would be useful. If anyone has any thoughts or advice, please share. Should I request that Asus replace the entire laptop? This is an out of the box issue.

1,613 Views
33 REPLIES 33

Hawrami
Level 9

I just want to add that my laptop is doing the same, im getting playback error while watching series, my mouse stops working and not only that but the integrated keyboard stops working all at the same time, ive been trying to do whatever it takes to fix the problem but im slowly giving up.

I would appreciate some help because this is very frustrating.

Is your camera flickering or glitching as well? Open the camera app on windows and see if this happens when the issue is exhibited.

Just making sure you have the same exact problem I have.

I wish I could help but I'm in the same boat as you. I have been talking to a customer service agent, and they suspect it could be caused by specific device incompatibilities. What brand/model USB devices are you using?

I am using a Deltaco USB Hubb 3.0

Is that all? I assume you have something attached to the USB hub. Also, what happens if you unplug and reattach the USB devices after experiencing the failure? Do you get an error when the laptop tries to recognize them?

I do have a Cloud Flight dongle on it and a Logitech G502 mouse. Nothing happens when i unplug and reattach the devices, they are not working at all. Only solution is for me to restart the laptop.

Thats very interesting, because those are the exact same 2 devices I have attached. It seems like it could be device incompatibility. Hopefully a fix will come out.

Also, does the issue happen when you are using an Ethernet cord only? It doesnt happen when on wifi for me.

My Ethernet cable is on at all times, I have not tried to be on WIFI. Maybe I should?