cancel
Showing results for 
Search instead for 
Did you mean: 

ROG Strix G15 Advantage Edition Stuck in Extreme Power Saving Mode

RenoCrunch
Level 7

The Model is 

G513QY

I am hoping someone can help me. I have had my Laptop for 11 months. For the last month it is stuck in extreme power saving mode.
|I have reimaged it 3 or 4 times now.
I am running Win 11 Pro.
It will not use the 6800M at all or the Lighting.
In Armory Crate - Under Device -> System -> GPU Power Savings
There are no power option any more. Only the option to Allow pop-up notifaction and an empty list.
I tried downgrading the Bios from 331 to 320, but it updated itself on the next boot and made no difference.
I tried the unistall of armory crate before my 1st rteiamge and again without any difference.
I enabled and disabled Armory Crate in the BIOS.
I used only the Site Drives and updates inside My ASUS and Armory Crate.
I have the latest of BIOS, Updated GPU BIOS, Passes all test in MyASUS.
But a gaming laptop is not worth much without a dedicated GPU. 
Herer are the screen shots from where I am at.
Did they move the setting?
Am I in need of sleep?
Is there any other way to control the GPU?
It is not in Windows Power setting those are at MAX performance anyway.
It is on AC.
It shows it is on AC.
I am not sure what to do. I sent emails to Support and they seem to think I just need to select a different power mode, but the options are no longer there. 
Screenshot 2023-10-30 134455.pngScreenshot 2023-10-30 133152.pngScreenshot 2023-10-30 134428.png

I have the latest Bios. I tried backingout ot 3.31

991 Views
3 REPLIES 3

Anbby_ROG
Customer Service Agent

Hi @RenoCrunch ,

Have you tried restoring the BIOS to its default settings? 
After restoring the BIOS to default values, please use an uninstall tool to remove Armory Crate and then reinstall it to see if it improves the situation. Thank you.

YEs, more than once. I did complete reinstall of Windows 4 times now. I tried default BIOS settings every time and leave them there. I tried uninstall just now and getting 2 frames per second in my game. I keep getting email from ASUS telling me to choose turbo mode, but they are no longer qhy options in my Armory Crate and it is stuck in extreme power saving mode for everything. I have 3 desktops I built with Tuf and ROG. I have had ASUS since my 1st AMD Phenom. This is horrid. My expensive laptop is so slow and will not play anything. 

Anbby_ROG
Customer Service Agent

Hi @RenoCrunch ,

Could you please check in your device manager to see if your dGPU information is displayed? 

If you find the dGPU information in the device manager, kindly navigate to AMD Software: Adrenalin Edition, click on [Settings], then [Display], and in the AMD SmartAccess graphics card section, select [Apply Hybrid Graphics Mode]. This will disable the SmartAccess graphics card feature. Please test and see if this improves the situation. Thank you!