cancel
Showing results for 
Search instead for 
Did you mean: 

ROG Scar Strix AMD Ryzen9 2023 4090RTX (G733PY) - secondary monitor wont show image

Drolx
Level 8

I recently purchased new laptop (ROG Scar Strix AMD Ryzen9 2023 4090RTX (G733PY).
Previously had G733QS.

I have my secondary monitor DELL curved wide and on previous laptop everything worked well.

Now it doesn't showe image on DELL screen. Monitor says No USB-C signal from your device.

If I reboot my new laptop approximately 200 times it occasionally starts using secont monitor.

Please help me what to do further in order to fix this?

354 Views
4 REPLIES 4

Anbby_ROG
Customer Service Agent

Hi @Drolx ,

Have you updated your BIOS (version 324) and NVIDIA display driver (version V31.0.15.2883) to the latest versions?
Additionally, could you please try using different USB-C cables for cross-testing to determine if the issue is caused by cables?
You can refer to the instructions in the following link to troubleshoot this problem:
https://www.asus.com/support/FAQ/1047158/#Win11

If you have any other concerns, please feel free to let us know. Thank you.

BIOS is latest versions as MyAsus says "Yuur device is up to date".
Armoury carate shows no updates. Windows is updated to latest version.
nVidia drivers are the newsest (tried both Studio driver and Game Ready driver).
I tested it with 3 different USB-C cables (each different but all three are high speed cables). I tested those USB-C cables in both USB-C laptop ports.
I also tested it with two USB-C to DisplayPort cables (on 4K 60Hz other 8K 60 Hz). I tried it all with all other USB devices plugged out.
I tried reinstalling all drivers that related to USB (all eXtensible Host Controllers, Composite devices, USB Hubs, USB Feature controller). 

It always acts the same.
I can replicate an issue every single day when I turn on my computer for the first time that day. Every day I turn it on main monitor doesn't receive any signal.
I learned that I can somehow "trick it", I go into BIOS, save the unchanged setting settings, reboot laptop, then turn it off completely for 2 seconds then start it up and main monitor somehow receives signal all of the sudden.
Sometimes USB keyboard doesnt start up so I need to replug it. Sometimes it happens to StreamDeck device and I need to replug it top work. But replugging doesnt help monitor signal.
That is very bad experience from 4K Euro laptop. 
Sincerely to me it looks like power to USB port issue or some driver no starting it up correctly. 

One more thing, this laptop never goes to sleep. I have to turn it off completely (Shutdown) every and each time as the fans keep spinning when "in sleep".

Anbby_ROG
Customer Service Agent

Hi @Drolx ,

 

Based on your description, we kindly request you to send your laptop to the local authorized repair center for further hardware diagnostics.
Since you mentioned that you have recently purchased the product, in order to ensure your rights , we recommend you contact the retailer for further assistance. Thank you.