Showing results for 
Search instead for 
Did you mean: 

ROG Keyboard Firmware Update V. Failing

Level 7

MyASUS had a critical update, but it has continued to fail me at every turn. 😞



I've tried everything I can find with no avail, and my laptop's keyboard has been disabled and unresponsive.

I've been looking into manually installing it through the ASUS website, but there's nothing available related to this either.

My model is a ROG Strix G16 Gaming Laptop, if it helps... G614JI, Windows 11 64-bit.


Accepted Solutions

Level 7

Update on this: contacted MyASUS support and tried everything they threw at me.

Unfortunately they had no solutions that worked, and what it came down to was to do a hard reset on the computer entirety after a backup... T___T

I hope y'all have better luck than me.

View solution in original post

Customer Service Agent

Thank you all for bringing this issue to our attention.

We have a solution in place for this problem. Please visit the download center, search for your product model, and download/install the ROG Keyboard Firmware Update tool version V3.8.3.007/V3.8.3.008 (varies by model) to resolve the issue. Thank you.

View solution in original post


Level 7

Me also got issues same u 😭


Level 7

i have g614jv and my problem is it failed on the install but myasus thinks it was a succesfull install. still the fw update is nowhere online. both the keyboard fw update and the nkey fw update failed and gone

my G834JY also received the update and failed but MyAsus marked it as complete.  in device manager I see it now fails to load the driver for the device.  Need some help to get this to work.


Customer Service Agent

Hi @yint @vin1114 @mirt1993 @Kantana ,

Thank you for reporting this issue. In order to expedite the resolution process, could you please provide the following information through private message? I will forward it to our internal team for further investigation. Your cooperation is greatly appreciated.

  • Latop Serial Number:
  • BIOS Version:
  • Windows Build Version (Settings - System - About):
  • Armoury Crate  > Settings > About > Service Version > Check Button (Copy all content😞
  • Armoury Crate log: In Armoury Crate, go to "Settings" and check the "About" page. If you click on "App Diagnostics" and choose "Record Log," the Privacy Policy Statement will appear. Once you agree to the statement, Armoury Crate will start collecting problem logs. You can then click "Generate log data" to create the log file with encrypted (ASUS log file).

Sent in PM, pls check.

I have a g614jv and my filmware install failed (myasus thinks it was successful). My problem is not so bad as I still have keyboard functionality. However, at random times some keys stop responding, and after a while, they start responding again (those same keys respond if I press another key in conjunction). Since my problem is not so bad should I wait for a new hotfix?

@Anbby_ROG , do you whant me to also PM the info that you requested to other users?

Customer Service Agent

Hi @BestDM ,

Due to the need for your personal information.
I have sent you a message, please check✉. Thank you

Level 9

Did you observe the troubles started a few days after a new BIOS-update was available for your PC?


Please check the version of your current BIOS. You can do it this way:

Right click the Windows symbol and start PowerShell and type or paste:

wmic bios get smbiosbiosversion

Then hit enter and Windows will print the bios version.

If you are using the new version 312 then consider to go back to 308.



Thanks Shabbat but I have the 18" version G834JY and I'm on bios ver 321.  The problem started when MyAsus tried to update the keyboard version last week.  It failed but after a few reboots, MyAsus reported it was successfully installed.