Showing results for 
Search instead for 
Did you mean: 

Rog Flow X13 Battery Does not Provide Power or Charge

Level 8


My Asus Rog Flow X13 (GV301RE, 2022), recently stopped using the battery. It does not charge and when unplugging the device from power it immediately turns off. My asus tells me that everything is fine and the battery moves between 9 and 10%. So far I tried:

  • reinstalling windows (resetting via local installation)
  • removing and reinstalling battery drivers
  • booting a linux distribution from usb to see if it chargers there (nope)
  • staying in bios to see if it charges there (nope)
  • updating BIOS to latest version (there was an option to force the update despite the low battery)

Unfortunately, nothing helped so far. The laptop is still in warranty however, I am currently on a backpacking world trip and the laptop is anyways bought in the US where I don't really live nor will be any time soon... so the warranty does not really help (unfortunately Asus insists that the warranty only applies locally in the US).

Anyone with further ideas what to try? I am open to pretty much anything that does not straight forward void the warranty.




Customer Service Agent

Hi @tstroyer ,

Based on your description, there may be a hardware issue. ASUS products come with either international warranty or local warranty. If it's an international warranty, you can avail warranty services in regions where international warranty is supported. If your purchased product only has local warranty, you'll need to send the laptop back to the original purchasing location for warranty services. The dealer should provide relevant information at the time of purchase.
Could you please provide your product serial number and location via private message? I will assist you in further confirming the warranty region for your laptop. Thank you.

Level 8

Hi @Anbby_ROG , I was/am already in contact with the Asus team - which unfortunately is not very helpful in my specific case. They informed me that I have a local US warranty so that repairs will only be possible in the US. As stated, making use of this repair is and will be impossible for me. I also got a list of things to try but unfortunately none worked (list below). What is weird is:

  • the issue exists even in Bios settings or when booting from a linux USB stick
  • the battery discharged one last time before giving up at least that is how the battery report looks to me 

Find below the battery report right after the issue started (so before all my OS re-installs).

Things I have tried:

  • Removing and re-installing all battery/power-related drivers
  • Re-installing windows from recovery
  • Updating the Bios (there was a way to force it despite the low battery)
  • Holding power button with and without AC-power for 15/20/60/120 seconds (yes... I tried everything).

Any other ideas? MyAsus recently came up with a new update which sound somehow related: PD Firmware Update tool. Any idea if this could fix things (PD as in power delivery? Quick fix? Yes!! Or?)? Unfortunately, I cannot install these because it complains that my battery is too low and it will disable usb-c for a moment  (which is a very very bad idea if that includes disabling my only power source 😉 ).

Thanks for replying and best,




Customer Service Agent

Hi @tstroyer ,

Based on the information provided, this situation may indicate a hardware issue, possibly with the battery or motherboard. 
The PD update you mentioned is unlikely related to this problem; instead, the failure to update could be due to a hardware abnormality, potentially resulting in the disabling of USB-C (which would be the worst-case scenario). We recommend scheduling a return to the US for diagnostic and repair within the warranty period. In the meantime, use AC charging as a temporary solution. This information is provided for your reference.