cancel
Showing results for 
Search instead for 
Did you mean: 

Recent MediaTek Driver Update Broke Network Adapter - ASUS ROG Flow x16

Space_Ace
Level 7

Returned home to find no wifi networks being displayed despite wifi being enabled.

Discovered this is due to a new driver roll out. Downloaded new driver from myASUS: "MediaTek WLAN Driver" , and installed to network adapter.

Problem persists.

Network adapter event log displays "Device PCI had a problem starting".

I have tried uninstalling and reinstalling the adapter, rolling back drivers, enabling and disabling, and performing network reset. Device will not start.

As it stands it looks like the roll out of this driver has completely ruined my device network capability. 

Beyond frustrated. Advice appreciated. 

 

97 Views
1 REPLY 1

Anbby_ROG
Customer Service Agent

Hi @Space_Ace ,

Please tried removing the power supply and all external devices while the device is powered off, pressing and holding the power button for 40 seconds, and then rebooting to see if there is any improvement?
In addition, I would like to confirm with you which BIOS version you are currently using? Thank you