Showing results for 
Search instead for 
Did you mean: 

RAM Upgrade Black Screen Tuf F15 FX516PC

Level 7

Hi all,

I recently tried to upgrade the RAM on my 2021 FX516PC. I have a dedicated RAM slot and 8GB soldered to the motherboard. I did extensive research and found that the RAM is upgradable to 40GB, so I went ahead and bought a 32GB, DDR4 3200MHz SODIMM Corsair Vengeance RAM stick. After installing it and turning the laptop back on, the screen was black but the keyboard was lit and the fans going. After numerous attempts to reseat the RAM and even flash the bios, I had no luck.

I returned the 32GB RAM to the shop and got a 16GB instead, on the off chance that maybe the RAM was faulty or the 32GB size was the problem (although the internet says it can take 32GB). After installing the 16GB today, I got the same black screen. 

The only thing I haven't tried yet is resetting the CMOS, but I have no idea where it is and haven't been able to find anything online. Has anyone had a similar issue or have any suggestions on a workaround?

Thanks in advance!


Customer Service Agent

Hi @mainstu ,

In confirmation, the FX516PC has a memory expansion slot, supporting a maximum of 16GB DDR4 3200MHz. It's worth mentioning that if you replace or add memory with different capacities or brands, the computer will need to perform a complete memory training during the next boot-up.

During the memory training process, there won't be any display on the screen, and the training typically takes about 1 to 3 minutes, depending on the size of your computer's memory. During this period, please ensure your computer is connected to a power source and avoid forcibly shutting it down. Let the computer complete the memory training on its own, and patiently wait for the display to appear. We provide this information for your reference. Thank you.

Thank you for your feedback. I'm using a 16GB DDR4 3200MHZ currently, part number CMSX16GX4M1A3200C22. I did attempt to install the memory and give the laptop time to complete memory training. I left the laptop for about 20min this morning and there was still no display, I left it for the whole day there was still no display with the fans speeding up every few minutes.

Is there a way to reset the CMOS or something that might assist with rebooting the memory training process incase that's the issue? Do you know of any other things I could try / test to eliminate variables?

Customer Service Agent

Hi @mainstu ,

Would you be able to privately message me your product serial number for further verification, please? Thank you.