cancel
Showing results for 
Search instead for 
Did you mean: 

Problem with BIOS of brand new ASUS ROG STRIX G17

Kakawet
Level 7

Hello all,

I have just bought a brand new ASUS ROG STRIX G17 with an AMD processor and an RTX 4070, and the laptop came without Windows so I had to install it myself.

So, the first thing I have done when getting the laptop is that I have installed a password on the BIOS (no particular reason for that but this will be an important detail later). Then afterwards I have prepared a bootable USB with the windows tool (https://www.microsoft.com/de-de/software-download/windows11) and plugged it into my new asus laptop. I thought it would boot directly on windows, but it did not happen and instead of that the computer kept restarting. I have to point out that the laptop did recognize the USB flash drive since I was able to see it on the BIOS, and that windows was correctly installed on the USB flash drive and that it was bootable (I tried on another PC). Also the Fast BOOT option was disabled.

Since it was not working I have used Rufus to re-install windows on the key (https://rufus.ie/en/), and with that the result I had was the following:

Kakawet_0-1712744566591.png

 

But then after this step, again the laptop just kept restarting and windows boot mgr was never launched.

After trying that I have decided to remove the password I had put on the BIOS, and after doing so I have used the 'Save and Exit' option of the bios, so the laptop start restarted but it never booted back on the BIOS. Instead I now have only a black screen and can not even enter the BIOS anymore.

So I am a bit stuck at the moment and not sure what to do, I went to a computer shop near my home but the guy was not really optimistic, he will get back to me tomorrow or the day after. In the meantime I would like to get advise from you guys and see if you can help me.

I have called the ASUS support but it was not helpful, the guy just send me to this page: https://www.asus.com/de/support/faq/1046347/ and told e that if that was not working I had to contact the retailer of the laptop.

I did the same post in the ROG STRIX series forum, not sure which forum would be the best one to post this issue (https://rog-forum.asus.com/t5/rog-gaming-notebooks/problem-with-bios-of-brand-new-asus-rog-strix-g17...).

Thank you in advance all !

169 Views
1 ACCEPTED SOLUTION

Accepted Solutions

Anbby_ROG
Customer Service Agent

Hi @Kakawet ,

Based on your description, it may be necessary to further diagnose the issue through assistance from a service center. 
Since you mentioned that you have recently purchased this product, to ensure your rights, we recommend contacting the retailer for further assistance. The above information is provided for your reference.

View solution in original post

1 REPLY 1

Anbby_ROG
Customer Service Agent

Hi @Kakawet ,

Based on your description, it may be necessary to further diagnose the issue through assistance from a service center. 
Since you mentioned that you have recently purchased this product, to ensure your rights, we recommend contacting the retailer for further assistance. The above information is provided for your reference.