cancel
Showing results for 
Search instead for 
Did you mean: 

Please help, wifi networks not showing

333AK333
Level 7

Good afternoon,

I hope you are doing well.

I have had many problems for the last couple of months as the Wifi icon keeps disappearing, and once it disappears I cannot use the internet until I restart the laptop. Once I restart, sometimes works for only a minute, and other times works for several hours.

These are the different things that I tried so far:

  • Network&internet - Advanced network settings - Network reset - Run

  • Get Help to troubleshoot and fix common connection problems. Right-click the network icon on the right side of the taskbar and select Diagnose network problems or open Get Help for Network & Internet

  • Update Drivers - downloaded from Windows as well as from my manufacturer.

  • Use old drivers

  • Up to date on Windows updates

  • Device Manager - update drivers/scan for hardware updates. Also, the WIFI device appears hidden when it stops working and gives two different errors depending on the time: Currently, this hardware device is not connected to the computer. (Code 45) To fix this problem, reconnect this hardware device to the computer. OR This device cannot start. (Code 10) {Operation Failed} The requested operation was unsuccessful.

  • Troubleshooter - Wifi is not connected, and it does not connect when using the troubleshooter

  • Powerflush

  • Restart your modem and wireless router.

  • It does not let me use the "System Restore" option.

  • I have also tried all the steps that appear in this link: https://support.microsoft.com/en-us/windows/fix-wi-fi-connection-issues-in-windows-9424a1f7-6a3b-65a...

Please note that the issue happens with different wifi networks, and the main wifi network works without any issues on my other three devices. I have also noticed that this always happens especially when I suspend my laptop and open it again after being unplugged from the electricity. But it also happens many other times while working and while using the laptop always connected to the electricity. 

I use W11 and my laptop is an asus tuf gaming f15 fx506he_fx506he.

Please help, I work remotely and this is killing me. 

Many thanks!

129 Views
1 REPLY 1

Anbby_ROG
Customer Service Agent

Hi @333AK333 ,

I would like to confirm if you have updated the BIOS to version 311. 
Please try removing all external devices and power sources while the device is in shutdown state. After that, press and hold the power button for 40 seconds, then reconnect the power source and boot up the device. Please use the officially verified MediaTek wireless network driver version V3.00.01.1294 and MediaTek Bluetooth driver version V1.3.17.155 to test if there is any improvement.
Based on your description, there may be a hardware issue. Please try using MyASUS to check for any hardware abnormalities. If the problem persists, we recommend that you take your laptop to a local service center for further hardware diagnostics. This information is provided for your reference. Thank you.