Showing results for 
Search instead for 
Did you mean: 

Laptop won't charge or boot up unless plugged in

Level 7

I bought my ROG Flow X13 less than a year ago and now it won't charge or boot up unless plugged it. It happened randomly when I was using the laptop and the battery fell to around 15% so I plugged it in. Then I noticed it hadn't charged at all after a few hours. So I unplugged it and my laptop just turned off. Now it wont turn on unless plugged it and won't charge at all. It is stuck randomly at 13-17% when i boot it up everytime and won't change from that number at all. Here's what I've tried:

  1. Hard Reset (40 seconds holding the power button, both with the cable connected and disconnected).

  2. Checked the battery health in MY ASUS, and it indicates that everything is okay.

  3. Uninstalled battery drivers in the device manager.

  4. Went to the BIOS and restored all settings to default.

  5. Tried using a different power outlet for the charger.

  6. Everything is up to date (BIOS, software, drivers, everything).

I'm considering disconnecting and reconnecting the CMOS battery according to suggestions I found online but I am a bit hesitant. What else can I do?


Level 7

Does connecting anything else to that top usb c port work (data device etc)? Have you tried connecting usb c power to the xog port (covered by large dust cover at bottom). I've the ROG XG Mobile & when connected can power the device from there. This could help identify if top usb port is damaged or if not charging from bottom then issue with battery or charging circuitry. (I'm just a user with  the Rog Flow Z13 (2022) Gz301ze-lc218w version. 

The port works fine. I tried the other port as well but it doesn't charge. 

Customer Service Agent

Hi @wizanyx ,

Based on your description, if the issue persists after performing a Hard Reset , we recommend that you take your laptop to a local service center for further hardware diagnostics to identify the problem. Thank you.