cancel
Showing results for 
Search instead for 
Did you mean: 

How to reset BIOS UEFI password on newest laptops like ASUS DASH F15 (2022 VERSION)

perfix
Level 8

Hello!

I wonder what private data is protected under BIOS settings if the user has forgotten his BIOS password or, as happened to me with ASUS TUF DASH F15, when I update the BIOS with my password I can no longer access it. I didn't go to the warranty service because the more my data is compromised by taking it to the service, I'm not sure when someone will copy it. To be honest, it's a good business module to make money on those users who have this problem...

A very wrong interpretation of the GDPR, or tailored to business requirements.

Yours sincerely,

Asus fan Andris

633 Views
1 ACCEPTED SOLUTION

Accepted Solutions

Thank you! I managed to fix the problem on my own.

View solution in original post

4 REPLIES 4

Anbby_ROG
Customer Service Agent

Hi @perfix ,

If you have set both an administrator password and a user password, when you enter the BIOS settings, you must enter the administrator password to access and modify the BIOS settings. If you enter the user password, you can only browse but cannot change the BIOS settings. 

The BIOS password is set by the user and is part of personal data. If you forget or lose the BIOS password and cannot use your device, please visit an authorized ASUS service center to resolve the issue. Repair fees may apply, but please rest assured that ASUS is committed to protecting and respecting your personal data. For more information, please refer to this link.

Hi! @Anbby_ROG ,

I had set the BIOS password only so that nobody could reset/update the BIOS without me being present. After last BIOS upgrade I could no longer access the BIOS admin profile to change settings. I could access everything because everything I needed was configured. The biggest problem was when a new BIOS version came out, I could no longer install it. The problem with this computer from the moment of purchase is that every now and then the connection ports don't work, which is annoying at times, as far as I read the last available upgrade fixed it. At the moment there is no point in taking it to the service, because the service is forced to change the whole motherboard (too very expensive) because of this safety regulation, absurd as it may seem. Plus I don't want anyone to touch my data. I sent this computer 1x to the warranty service, right after the purchase, because the NVMe slot screw was broken. After replacing this screw, the service for unknown reasons reinstalled the system OS, without my agreement.

I would like to warn users that for new ASUS computers it is better not to put the BIOS password at all.

Thank you! 🤝

Thank you! I managed to fix the problem on my own.

Hey prefix, 

May I ask how you solved it? I'm still having trouble!