cancel
Showing results for 
Search instead for 
Did you mean: 

HELP with Asus G70S Bios NVRam

Starfoxfs
Level 7

Hi,

i have a big Problem with my oldie but goldie Asus ROG G70S.

I think its an NVRam Problem.

G70s reboots directly after NVRAM is checked 1 Time and then 2nd HDD is lost in Bios, then it Boots from 1st HDD.

After Power Down the 2nd HDD is back in Bios and then the Step above.

The Controller, Connector and the HDD is fine ! I tried several HDD´s on 1st SATA and 2nd SATA Port.

I´m on a Repair Shop and the Connector has no issues.

How can i reset the corrupted NVRAM ?

I tried:
- Disconnect Battery Bios, Disconnect Battery Laptop, Disconnect Power (for 3 Days)
- I jumpered Pin 12 from Macronix Bios MX29LV800CT to Ground (it´s the Reset Pin)

- I tried flashing with Easy Flash (from Bios itself) but this don´t overwrite Bootblock or NVRAM only the normal Bios Block
- I tried Aflash2 Utility same as above don´t Overwrite the NVRAM and Bootblock

- I tried Afudos 4.14 with Attributs /P /B /N
Here i get the Error "Problem Erasing Flash 0F8000 (96%)

Other Afudos Version can´t gettin Flash Information.

What can i do ? what Utility overwrites the whole Bios ?

 

108 Views
2 REPLIES 2

Anbby_ROG
Customer Service Agent

Hi @Starfoxfs ,

Would you mind providing the following information via private message? This will help us further investigate your issue. Thank you for your cooperation.

Serial Number:
BIOS Version:
Installed HDD Model and Specifications:

Hi @Anbby_ROG,

i have sent you a Private Message with the Data.

Greetings,

Starfox