Showing results for 
Search instead for 
Did you mean: 

HAL V2.5.24.0 Install Error code 4152

Level 7



I am facing this issue.

Wherein I am unable to install HAL version  

as it is prompting the error code 4152  

Tried every possible way to install yet not installed. 



Customer Service Agent

Hi @paten ,

Regarding the issue of HAL not being able to update, there is now a new HAL v2.5.30 update available to resolve this problem.
Please try updating and feel free to let us know if you encounter any issues. Thank you.

Level 8

New version; same issue:

Screenshot 2023-06-19 085918.png

Yes same issues too, the new version cant update as well. 

Customer Service Agent

Hi @Solidus  @paten ,

I apologize for the inconvenience.
If it's convenient for you, could you please check the option to enable logging and click on the update button once more?
After that, please provide me with the log file via private message. I will promptly forward it to the relevant team for further investigation. Thank you.

strangely after log record is on, the install works fine, strange...

I've gotten the same issue, id postpone the issue by uninstalling the latest update and using the old version since it also messes with my aura sync but im looking for a permanent fix. Ive tried everything record log button, uninstall reinstall and restarting. really don't know what else to doimage_2023-09-25_032059273.png

Customer Service Agent

Hi @Khlamidya ,

I'd like to confirm with you whether you have used the uninstall tool to remove Armoury Crate and then reinstalled it?
If you have already done so, but the issue still persists, could you please assist us by enabling the logging feature, running the update again, and providing us with the log file along with your product serial number? This will help us investigate and address the problem. Thank you.

【Here is the file path for the log file for your reference】 
In Armoury Crate "Settings" and check "About" page, If clicking App Diagnostics "Record Log", the Privacy Policy Statement will pop out. Once user agreed statement, the Armoury Crate will start to collect problem log  and you can click "Generate log data" to generate the log file with encrypted (ASUS log file).

i did try uninstalling but somehow magically it allowed me to install without me doing anything after i sent the message, but still had my aura sync issue which also somehow someway magically disappeared today. really lost on how but i hope ROG stops with the trigger happy updates that cause more issues than they fix. Thanks for your help though!