Showing results for 
Search instead for 
Did you mean: 

GA503RW Keyboard Issue

Level 8

okay so i have run into issue of keyboard just plain out dead. all of the keys have stopped.(exception power key). no backlight.not even working in uefi.  i have checked everything. used Myasus app to update firmware which fails gives Keybaord firmware failure. or get stuck at 50%. i have checkedd logs of the firmware update and it last line says 

[Initialize] Battery Power Level : 98
[Initialize] GetASUSDevice fail
[Initialize] GetITEDevice

in armory crate when i select Aura effects(where i was able to change keyboard backlight color schemes) it says No Device Available, Please conect aura sync device(which never happened before). 

I have done clean windows uninstall and trying to update keyboard firmware through myasus app.same error. update bios. reset it to default. open up laptop and unplug keyboard connect and reinset again to check if somehow it got loose. but still nothing. reset drivers in device manager.still nothing. reinstalled armory crate and myasus app. still nothing. did clean windows install multiple times.

My guess is that keyboard is just borked. 

what i want to know if i change keyboard i.e get a replacement and insert. will it work? anyone with experience? is it a bios problem? can someone guide me to right direction? i am comfortable with opening laptops and changing stuff. laptop is just 2 months above warranty so cant claim it. i love this laptop but this keyboard stuff is bugging me alot and im sick of using an external keyboard.


Customer Service Agent

Hi @usamaasif1994 ,

Please try the following steps in order to address the issue:

  1. Remove ASUS System Control Interface v3 and uninstall Armoury Crate using the provided uninstall tool.
  2. Reinstall ASUS System Control Interface v3 version V3.1.22.0 and Armoury Crate.

Additionally, please disconnect all external devices when powered off. Long-press the power button for 40 seconds to perform an EC reset. Afterward, reconnect the power and boot up the system to test and see if there is any improvement.Thank you.

I followed your guide but it didnt solved my issue. i was able to find Asus service center in my area and went there to get it checked. they performed your same procedure as well. did a clean windows reinstall and updated bios and kb firmware as well and still nothing. they checked using ADK in linux and informed me in the end that its a hardware issue and i have to get it replaced. since my warranty just expired i was unable to get anything more than that. but good thing atleast they helped me pinpoint the fault. its hardware issue. now im off to find a replacement. fingers crossed 

Customer Service Agent

Hi @usamaasif1994 ,

Thank you for your update. If you have any further concerns or questions, please feel free to let us know .