Showing results for 
Search instead for 
Did you mean: 

Flow Z13 Power Adaptor not being detected occasionally

Level 7
I've had the Flow Z13 for a month now and so far, everything seems great! There's just one issue that I've been having so I'm wondering if others have had similar issues?

I use my Flow Z13 with CalDigit TS4 dock - connecting to the dock via Thunderbolt 4 and then to an external monitor via USB-C display. Occasionally - like once a week or so, the Thunderbolt 4 port would not "detect" the dock or display. To make things even worse, it won't detect any power source that gets connected to the Thunderbolt 4 port, nor the USB-C in the XG Mobile connector. I've tried both of these ports using the official Asus 100W adaptor that came with it and other USB-C power source but when this happens, the Z13 doesn't detect anything (the orange light next to the Thunderbolt 4 port does not light up).

I've also use MyASUS diagnostics when this happen but the power source/adaoptor, including Asus' own, doesn't get picked up at all. After a few shut down/ startup and restart cycles, the issue would "go away" and the power adaptor is detected normally. I haven't figured out the sequence to make "it work" yet but once this happens, the charge light comes back on again and everything "works as it should". Thunderbolt 4 port is detected, Z13 gets charged, and the display works.

Anyone experienced this and perhaps have some tips/advice?

Hi Anbby,
I updated my bios version directly when I got it last July. I have the GZ301ZE. I see the last bios version is from May, so I already have that one. 
I uninstalled the ASUS System Control Interface v3 from Device Manager > System Devices. Then I reinstalled it with from:
It gave me a notice that NOT all functionality was compatible with my hardware, but gave me no indication of what was not compatible precisely.
Screenshot of what happens when plugging in the Thunderbolt device when it is not recognized.Screenshot of what happens when plugging in the Thunderbolt device when it is not recognized.
Yes, I am plugging the cord into the upper USB-C port next to the led, so not the one near the bottom with the other docking-related ports next to it. I will record a video of the behavior when I am home again tomorrow. For now: I attached a screenshot of the message of what occurs when I just plugged in the Thunderbolt cable, and the device is not recognized. When it is recognized after one or multiple restarts everything works fine, and the devices connected to the Thunderbolt turn on correctly. The last time it did work, I had the Thunderbolt port plugged in before I started the computer. I am not sure if this works consistently. I will try again multiple times tomorrow.

Thank you for looking into this!

Customer Service Agent

Hi @AmberE ,

Regarding ASUS System Control Interface v3, you can download the version for GZ301ZE from here
Additionally, I'd like to confirm if you are using the power adapter that came with the device?
This message is intended to inform you that for optimal performance, it's recommended to use the original power adapter to ensure a complete laptop performance experience. The provided information is for your reference.

Hi Annby,

Sorry for my late reply, I was working at another location so couldn't test further. Which driver contains the System control interface on the link you sent? I see a lot of drivers, but am not sure which one would contain it. I reinstalled the Serial IO bus one now in the hope that was it.

My docking station does not allow for your power supply via that port, but even if I attach your power supply to the second port, the Thunderbolt device is still not recognized (which is my main concern, I know about performance limits without the original power supply).

In the meantime I also noticed that sometimes if I continue working or just leave my pc alone while it does not work, suddenly the Thunderbolt device is detected and everything works. This sometimes takes 5 minutes after startup or plugging it in, sometimes an hour or more, sometimes it does not seem to happen at all. Once it works, it works until I unplug it or turn the system of. Even if I touch nothing after shutdown (pc, cable and thunderbolt device), and start it back up, I'm back to the same problem of just having to get lucky for it to work at some point.

I think maybe this laptop is just not checking enough in the drivers whether there is a Thunderbolt device attached? I never had these problems with my previous laptop. There it always detected it instantly after I plugged it in (same cable and Thunderbolt setup).

Customer Service Agent

Hi @AmberE ,

Thank you for providing detailed information. 

Based on your description, we recommend that you send the product to your local authorized repair center for further hardware diagnostics to ensure its normal operation in the future. We apologize for any inconvenience this may cause.