cancel
Showing results for 
Search instead for 
Did you mean: 

Finally here to try and fix my ASUS ROG STRIX G15 G513QR

Eugene98120
Level 8

EDIT: For TL;DR PROBLEMS HERE: RESETTING THE PC (POSSIBLY MANY TIMES) FROM RECOVERY OPTIONS IN WINDOWS 11 MAY CAUSE/CREATE INSTABILITY. CRASHES AND FREEZES ON STARTUPS OCCUR. 

FIXED WITH A USB-C FLASH DRIVE WINDOWS MEDIA INSTALLATION FILE, LOST FUNCTION TO ARMORY CRATE COMMUNICATING WITH AURA OR BACKLIT KEYBOARD, FREEZING CAN STILL OCCUR ON SPECIFIC DRIVERS (AMD Adrenaline software 23.9.3 and above) 

MANY RED ERRORS AND SOME FORCED SHUTDOWNS LOGGED ON EVENT VIEWER. (ex. "Session "CldFltLog" failed to start with the following error: 0xC0000022", "Session "PerfDiag Logger" failed to start with the following error: 0xC0000035", "Faulting application name: WindowsPackageManagerServer.exe, version: 1.17.2203.10001, time stamp: 0x622a8641
Faulting module name: WindowsPackageManager.dll, version: 1.17.2203.10001, time stamp: 0x622a8613", "The ArmouryCrateControlInterface service failed to start due to the following error:
The service did not respond to the start or control request in a timely fashion."

I have done all the troubleshooting that one could possibly do on this laptop, and it started 2 weeks ago when my laptop started freezing/crashing on startup. The result on October 13th was a AMD Driver 23.9.1 and beyond, and uninstalling the AMD display adapter driver in device manager for the AMD Ryzen 9 5900HX solved the problem of the freezing during use. But the problem came back after I cleaned my laptop by resetting the PC through windows update to try and declutter my 2 years of data. This time, after Resetting the PC while retaining my personal data proved to degrade the computers stability and performance. 

A little backstory:

I use this computer as my daily driver for everything, but it doesn't see varying environmental hazards since it is mostly at home. I usually use the option of Reset my PC on Windows 11 with the option of retaining my personal files to declutter and get rid of old drivers possibly (if that option does actually remove drivers), and the problem that arose on October 13th was happening again.  On the 13th, I had to go into command prompt and quickly, during startup, try to access windows recovery environment, with many failed attempts because of freezing, and anything windows related that was trying to come up would be met with a crash and freeze, until I got lucky and went through going through windows recovery to somehow got enough time get to Windows 11 recovery in the settings of the OS to access Reset this PC while retaining my data to get to the Windows 11 setup, access my restore options to restore to October 11th, without the AMD driver.  Sidenote* I have OCD and I reset my computer many times, I think to maybe already 30s-40s number of times. I hope that resetting a PC much doesn't damage the PC itself, so I asked and searched around the web and community, looking for the fix to this, and came upon many more people with many more problems.

now, the problems:

The problem that caused my computer to crash on Oct 13 again was, allegedly, largely AMD driver related settings. I heard from others in the community say that TPM 2.0, Windows 11 updates and Windows itself caused their crashes. I went to Reset my PC on October 29th and retain my data only to find the crashing happened again, even without the presence of the current AMD driver. I went through event viewer and found MANY errors and already knew the several criticals that came due to the forced shutdown to get the computer to try and boot again without freezing on bootup screen, but what was notable was that on October 29th, I had to go through command prompt on the "The computer restarted unexpectedly or encountered an unexpected. Windows installation cannot proceed to install Windows, click ok to restart the computer, and then restart installation" error with win+f10 because that error kept looping trying to get to windows setup. 

I first had to try my luck at restarting the computer after every freeze until i could use the Win+f10 keys to get into the command prompt to access the registry editor in Childcompletion under HKEY LOCAL MACHINE and change the last digit of the setup.exe value from 1 to 3. The setup and reinstallation went smoothly after that and I could access Windows 11. Then came another problem. My backlit keyboard wasn't responding to the armoury crate, and I had did a clean uninstall of armoury crate from the ASUS website, and reinstalled for the backlight to still not respond. 

I reset the PC to see if armoury crate would respond after resetting and downloading the armoury crate installer to no avail. Another Reset this PC happened again because after the backlight stopped responding this time, I reset this PC with the option to clean the drive and all other drives connected to the PC (the default C: drive NVME SSD, and the extra 2TB 😧 drive NVME SSD) and reinstall windows from the device because I was guessing it was software related, and could be related to any of my applications, drivers etc. After the reset when my computer rebooted up after setting up, there were freezing issues again and keyboard lights still wouldn't light up after initial bootup (it does light up when I turn this laptop on again) I had to use the final resort which was made after the computer could no longer boot into the OS drive, I downloaded a Windows Media Installation tool into my USB C flash drive and booted the laptop from the flash drive after setting boot priority, the computer would finally work after using setup to not just format, but delete the main partition of everything including the now corrupt windows inside it, to use the Media Creation Tool from the USB C on the previous C: drive as the place to replace my old OS data and everything that had broken it. It's in an operable state now but the backlit keyboard still doesn't work and I'm still guessing it may still be software related issue that still persisted, or maybe it could be a hardware issue now, but also I noticed this laptop and the new recently bought FLOW X16 has a lot of red errors and warnings, which is concerning.

2,003 Views
1 ACCEPTED SOLUTION

Accepted Solutions

Finally figured it out by going into general settings in lighting and flipping the switches for the on off indicators for lighting. WOW thank god!

View solution in original post

4 REPLIES 4

Anbby_ROG
Customer Service Agent

Hi @Eugene98120 ,

Based on your description, the issue might be caused by missing drivers. Before we proceed with further troubleshooting, we would like to confirm if your BIOS has been updated to the latest version 331.

Please use the uninstall tool to remove Armoury Crate, install ASUS System Control Interface version V3.1.20.0, and then reinstall Armoury Crate. After doing this, please test if your keyboard backlight can be adjusted properly. Thank you.
 

Due to the ongoing regional holidays, my responses may be slightly delayed.
Thank you in advance for your patience.‌‌‌‌

I'll try this, thanks for the suggestion!
If I don't get back real soon, probably means my laptop is either freezing or crashing. 

Hi again Anbby,

I used the Armoury Crate Uninstaller tool from the website for Armoury Crate - Support (asus.com) and installed Asus System Control Interface V3.1.20.0 but the lighting on the keyboard still doesn't work/ respond to the Armoury Crate program or the RGB brightness keys. There is still a bug with the lighting software and I think there's a stability issue that comes from Windows 11, Armoury Crate Services, and AMD display adapter software. So far after my 4th hard reset (held power button for 40 seconds, would not recommend for practical use, but as a last resort) and after some freezes and crashes from booting up from the Asus logo to minutes after login of OS and then freezes, I finally got windows 11 to finally install. I had to take out the battery that is integrated on the inside of the computer and then unplug the power AC adapter and hold the power button again for about 30-40 seconds and upon almost thinking i bricked the laptop, the removal of the internal battery helped out with booting up the laptop again. This time is the same as last time, but If I don't touch any drivers or applications, this PC is functional except for the many event viewer errors and lighting problem, which may stem from the updates. I still need to figure out what is corrupted, because AMD drivers and system programs may be interfering with each other, and ASUS and Microsoft need to find a way to optimize the laptops that transitioned from windows 10 to windows 11 (laptops made in 2021) and I think ASUS needs a bit more time to put out a patch for those who lost the ASUS recovery option after upgrading from windows 10 to 11.

 

Finally figured it out by going into general settings in lighting and flipping the switches for the on off indicators for lighting. WOW thank god!