cancel
Showing results for 
Search instead for 
Did you mean: 

Dedicated GPU not used - Asus ROG Strix G15 Advantage Edition

dIABLOXX
Level 7

Hello everyone, I'm having an issue with my laptop (Asus ROG Strix G15 Advantage Edition). I just launched RDR2, but I noticed that it's running at 5 FPS. Then, I realized that the dedicated GPU is not being used. However, I've already enabled performance mode in the Windows graphics settings and updated the GPU drivers. I have this problem with several games, but what's odd is that I ran a benchmark (Heaven Benchmark 4.0), and it correctly utilized the dedicated GPU, thus delivering appropriate performance (~80FPS). Additionally, I tried disabling the integrated GPU in the device manager, but this caused several errors in Windows, so I decided to re-enable it.

 

Here are my laptop's specifications:

- CPU: AMD Ryzen 9 5900HX
- GPU: AMD Radeon RX 6800M
- RAM: 16GB

How can I fix this problem?

 

dedcated gpu not used in Gamesdedcated gpu not used in GamesGraphic Settings set on dedicated GPUGraphic Settings set on dedicated GPU

347 Views
6 REPLIES 6

Anbby_ROG
Customer Service Agent

Hi @dIABLOXX ,

Have you updated your BIOS to the latest version 331 and tested with the ASUS validated AMD display driver version V30.0.13002.13003
Additionally, I'd like to confirm if you have been using an external monitor. Please try setting the GPU configuration in Armoury Crate to Standard mode during gaming to see if there's any improvement. Thank you.

My BIOS was not updated, i will feedback 

QQ02
Level 11

Also does the issue persist in other games as well or is it specific to RDR2 non-benchmark?

The question about external displays is also very relevant as it may depend on which port of the computer you use for connecting to the external display, as is whether you are using the laptop on battery power (power saver settings) or plugged in.

the issue persist on other games. And I use only the laptop screen, no external displays. And I used turbo mode, so my laptop was plugged.  

C-V-N
Level 12

Check out this video it may help it did once for me.

https://www.youtube.com/watch?v=J0QFyJeNkYo 

It's for NVIDIA GPU, I have AMD 😞