cancel
Showing results for 
Search instead for 
Did you mean: 

ASUS ROG Strix G814JI keeps on freezing with blinking orange battery light while plugged in

alphachino
Level 8

Recently bought an ROG G18 laptop however it's completely unplayable 5-15 min. into the game the laptop completely freezes and becomes unresponsive while there is a blinking orange light. This happens when gaming while plugged in. Tried to game on battery and it runs smoothly.

Things I have tried so far:

  1. Edit power plans/options

  2. Update drivers

  3. Uninstall/Reinstall drivers

  4. Uninstall/Reinstall Armoury Crate

  5. Factory Reset PC via Windows settings AND ASUS Cloud Recovery

  6. Clean install Windows 11

Nothing fixed it still having the same problems over and over.
Video posted for reference (this is when I clean install windows 11 while updating drivers and ms store apps)

Videos:

https://drive.google.com/file/d/1w6nJZ5smLvjh3grTDrIyhoHr__82pmUx/view?usp=sharing
https://drive.google.com/file/d/1VJhdPBoFVa7c6tSuI7vCC7YDNFbX_Vei/view?usp=sharing

575 Views
11 REPLIES 11

Anbby_ROG
Customer Service Agent

Hi @alphachino ,

I'd like to confirm if you've already updated the BIOS to the latest version 324 and tested by restoring the BIOS settings to default values.
Based on your description, the issue seems to occur only when plugged in. May I ask if you are using the original 280W AC Adapter provided by the manufacturer?
Please power off the device, disconnect all external devices and power sources, perform an EC reset by holding down the power button for 40 seconds, then reconnect the power and boot up to see if there's any improvement. Thank you.

Hi @Anbby_ROG,

Thank you for your response. Yes I have updated bios to 324 and restored default settings of bios everytime I do cloud recovery or reformat. I am also using the original AC Adapter included in the box. I also have tried holding the power button for 1 min but the issue still persists.

alphachino
Level 8

*Update

I think I found a fix (I was able to complete 1 game of dota 2 without any issues but I am still testing it)
If I lessen the e-cores on CPU core configuration on armoury crate it seems to fix the problem however isn't it suppose to handle that configuration because by default it was set to 8 p-cores and 16 e-cores.

Correct me if I'm wrong about it

Anbby_ROG
Customer Service Agent

Hi @alphachino ,

Thank you for the update. Could you please provide your product serial number and a screenshot of the e-cores settings in Armoury Crate via private message, so we can further investigate? Thank you.

Sending you a private message

Printpunks3d
Level 7

Did you get anywhere with this I’m having the same issue 

Hi @Printpunks3d,

Yes I was advised by @Anbby_ROG that it was a hardware issue so I brought mine to a service center, which they also confirmed.

 

Will update once holidays are over

Hari_Honey
Level 7

Same problem what was the hardware issue?

Anbby_ROG
Customer Service Agent

Hi @Hari_Honey ,

Could you please share with us the model number of your product and describe the issue you are experiencing? Thank you.