Showing results for 
Search instead for 
Did you mean: 

ASUS rog strix G17 won't wake up from sleep mode.

Level 8

I have been using my Asus Rog Strix G17 computer for about a month. My computer does not go into sleep mode and does not wake up when it does. It does not wake up even though I click the power button, keyboard and mouse. I keep getting karnel power 41 error in the event log. Please help me. Otherwise I'll go crazy. 


Level 12

Kernel power 41 means your system wasn't able to go through the routine shutdown procedure and instead had something else cause a crash.

When my computer does not wake up from sleep mode, I have to long press the power button to turn it off. I think this is what caused it. If I solve the sleep problem, the error will also be corrected. 

Level 12

Yeah everybody who gets stuck cause of the sleep mode problem does this but doing it to much could cause harm to your system.

Do you have a usb keyboard and mouse pugged into your system? 

If so unplug and put your system into sleep mode an see if it happens again. 

I know I had this issues as well with my devices plugged, I started unplugging devices before I shut down or use sleep mode.

Only the mouse was connected, not the keyboard. I removed it and tried it again, the same thing happened. 

Customer Service Agent

Hi @Rogsuat ,

I would like to inquire if your BIOS has been updated to the latest version. Has the issue of being unable to wake from sleep only recently started occurring?
Please refer to the instructions provided in the following links to confirm whether the power plan settings are configured to meet your expected sleep mode. Additionally, please ensure that the settings related to waking up from sleep are properly configured. If you have any other concerns, please feel free to let us know. Thank you.


Unable to Enter Sleep or Hibernate Mode
Unable to Wake Up from Sleep or Hibernate Mode

The latest version of the BIOS is already installed. I have had this problem since the first week. I tried all the power plans and settings, but it still didn't work. I tried the methods in the links you posted, including system restore, but my problem was still not solved. 

Level 8

Armoury CratI wonder if it might be caused by the Armory Crate application. I also noticed this, when my computer is using the AMD graphics card, there is a screen flickering at the millisecond level. It doesn't always happen, but it happens occasionally. There is no problem with the NVIDIA graphics card, though. 

Level 8

I uninstalled the drivers with DDU and installed them again. It didn't work. Is it okay if I install the old driver?

If your older drivers worked an you didn't have any issues with them I'd say go for it.