Showing results for 
Search instead for 
Did you mean: 

ASUS ROG STRIX G16 (G614JI-AS94) BIOS crapped after windows auto-update

Level 8


I'm a bit confused by my new laptop BIOS crash on G614JI model.

To fix i've searched through forum and support portal and find solutions to reflash bios from usb.

I tried all flavours of bios file name includin .bin/.rom/AMIBOOT.ROM/BIN/AMI.ROM/.CAP and tried to boot with ctrl+home(fn+left arrow)+power, but without success, I'm still on instruction "..write bios file to flash, reboot, reflash.." screen to recover my bios.

Is it any sort of special keyboard combination i'm missing or special filename for strix g16?

Will apprectiate any help...or will go to service to reflash by hardware options...

Thanks in advance


Customer Service Agent

Hi @zorg-bessarab ,

I would like to gather more information in order to assist you with your issue.
May I  confirm if you are currently able to access the system?
Please tried following the instructions provided in the link below to update the BIOS.

If you are still unable to complete the BIOS update using the information provided, and to avoid any potential hardware issues caused by incorrect operations, we recommend taking your computer to a service center for assistance. Thank you.

Hi, thanks for your help.

For now every boot I see only black screen with text:rn_image_picker_lib_temp_dd9e5f03-8eb6-4a18-909f-7fcce5d6aa60.jpg


I tried this instruction as well, but i stacked with same screen (seems like bios files are not identified). I tried 4/4/32GB flash drives with FAT/FAT32 FS and tried all sort of file-naming from forum. Also i tried to replace nvme ssd from another laptor with bios files on root dir. Same result. To start bios flash I tried to boot with following key bind - ctrl + fn + left-arrow + power.

Maybe I've done something wrong. Also the case that form this picture:rn_image_picker_lib_temp_709c57e2-1971-4d5c-ab62-23dcee98eb89.jpg

That system tried to update from 303 to 309, but on support site only 309/312 available for my model.

Customer Service Agent

Hi @zorg-bessarab ,

Based on your description and the images provided, it appears that the BIOS is unable to recognize the update file you downloaded. 
If you have already tried formatting the USB drive, redownloading the update file, and extracting it onto the USB drive but it still cannot be recognized. 
It is recommended to take your computer to a service center for assistance,to avoid any potential hardware issues caused by incorrect operations ,Thank you.

thanks...already did that

Level 8


The case was solved by service center without bios reflash with programmer.

But after update attempt to 313 the same is here!!! BIOS update failed.

Now I'm able to recognise USB flash and bios file, but every update attempt failed...

I tried both file for EZ flash and extract update from update for windows, the same result...

Seems like Asus Update is a rubbish...

Customer Service Agent

Hi @zorg-bessarab ,

Apologize for the inconvenience caused, and I believe there may be some questions we need to understand in the process.

May I ask how you initially updated the BIOS?

If it's convenient for you, could you please provide me with your product serial number and the repair number from your last visit to the service center via private message? I will verify your machine's status with the service center. Thank you.

Hello zorg! 

Could you solve it without taking the equipment to the technical service? 

Customer Service Agent

Hi @SrPerry ,

May I confirm whether you can currently access the system?
If you have already attempted the provided methods above and are still unable to complete the BIOS update, to prevent any potential hardware issues due to incorrect operations, we recommend that you take your laptop to a service center for assistance. 
Apologize for any inconvenience this may cause.

Hi, no. It's still not possible. I've deleted ASUS Support utility just not to give them a chance to update.

So after 3 time!!! visiting Asus Support Centers (they "can't find and issues" and update BIOS with JIG adapter), I decided to freeze BIOS updates (i'm on version 314 i believe).

No one can describe me why updates from official ASUS utility doesn't work.