cancel
Showing results for 
Search instead for 
Did you mean: 

ASUS ROG Strix G15 G513RC-HN088 keyboard lagging and missing keystrokes

LeoFox2023
Level 7

A few days ago I bought this laptop and I'm really satisfied with its hardware.

Nevertheless, there is one thing that keeps me extremely annoyed these days: the laptop keyboard. 

I started noticing that immediately after installing Windows 11. At some point, the keyboard would just "go to sleep" and not register first 1-2 seconds of inputting after some time of not typing. The issue got resolved after installing all the drivers, armory crate, etc. But that was only the beginning to the whole keyboard problem. The keyboard often feels like there is input lag. It's not really noticeable for any 3rd person to see, but when you're typing fast (that's what I'm used to) it feels like inputs are displayed with a delay. Sometimes, the delay is so bad to the point where characters in the word are written in a wrong order, for example, instead of "ASUS" it types "AUSS", or something like that. Sometimes there are double inputs registered, when there is only one. That happens rarely though. The most annoying problem with the keyboard is that it often just doesn't register my inputs when I clearly press the keys, and ANY key on the keyboard can act like this, not just letters. For example "wanna see" can become "wannasee" due to spacebar not registering my input, and so on. Writing this post alone it has skipped circa 15-20 inputs.

What I've tried already to no avail (reading other posts from this forum as well):

- Reinstalling Windows multiple times

- Updating BIOS

- Removing Armory Crate and MyAsus apps using Revo Uninstaller

- Disabling all services that the aforementioned apps provided

- Going to power management settings in Device Manager and disabling to temporarily turn off devices like USB (generally all devices that had the checkbox)

- Switching directly to the RTX GPU and disabling the Ryzen iGPU in the Device Manager

- Setting keyboard lighting pattern to Aura Sync (and adjusting my keyboard from the app)

- Removing the touchpad from device manager

- Removing bluetooth adapter from device manager 

- Removing keyboard from HID devices and reinstalling them back

- Running Manjaro Linux from LiveCD

- Updating all drivers from windows update, Geforce Experience, AMD Adrenalin and ASUS website

- Pressing and holding the power button for 60 seconds to reset Wifi and Bluetooth

- Disabling fast boot and secure boot in bios

- Unplugging all USB devices

 

What I haven't tried but will in a few days:

- Connecting my Keychron K3 keyboard via USB and try to use it, but some people have reported this bug doesn't affect 3rd party keyboards.

 

One interesting thing I noticed is that this behaviour doesn't start immediately after a reboot. During first 5-10 minutes input lag is almost unnoticeable, then, as I start using my laptop, this behaviour only becomes worse and worse. So i believe this problem is not on the hardware level, and it CAN work normally.

Please share your solutions if you found them, cause it sucks to buy a laptop this expensive and get my keyboard screwed up like this 😞

 

 

 

 

447 Views
1 REPLY 1

Anbby_ROG
Customer Service Agent

Hi @LeoFox2023 ,

I'd like to confirm whether your BIOS has been updated to the latest version 327. Based on your description, could you please try removing the ASUS System Control Interface v3 driver and then reinstall the latest version V3.1.20.0? Additionally, regarding the input delay issue, you can refer to the instructions in this link to adjust settings and see if it resolves the problem. Thank you.